FTP Client for CPF v3 rules

Hi Guys,

FTP Client more detailed instruction(s) specifically for v3 would be a nice thing to have, please.

1) I never had a problem using FTP Client in v2.
(using WinSCP from WinSCP :: Official Site :: Free SFTP and FTP client for Windows
One question from Comodo asked and confirmed and that was it.

2) after installing v3 on XP it times out because always blocked.

WinSCP.exe Blocked
Source Port = correct FTP IP
Source IP = 20
Destination IP correct 192.168.1.xx
Destination Port = always changes (1746, 1092…etc)

I can provide more info/images/etc. , if needed.

3) installed client on w2000 with Comodo v2 - no problems as expected

4) Sure I did search through the forum (not an easy task to find correct set of keywords :)… ) but given advices are mostly for v2 anyway

5) went to Predefined Firewall Policies
Created rule for FTP Client, it was added to App rules with Dest port 21 and so on …but to no avail

Should anything be added to Global Network Settings ?
Some Editing of default Comodo FTP Client Application rule must be done in addition?

Thanks in advance
My regards

To the predefined FTP client rules provided by Comodo, you need to add the rule for passive FTP:

Port 20 is for active FTP, which is not often used. See http://www.slacksite.com/other/ftp.html , for example, for more than you ever wanted to know about FTP. :wink:

Hi sded,

Thanks for replying.
I’ve added the rule as you advised to predefined FW Policy for FTP client
The result is the same (:SAD)
My regards

Do you have the “allow DNS rule” in your FTP ruleset?


Check your firewall log and let us know what is being blocked. The last rule under “ftp client” should be
block and log

I have modified the ruleset and don’t remember what the default was for Comodo 3. :slight_smile:

Hi sded and Guys,

Below are information & images.
I hope it will help to figure out what’s going on with the FTP Client

Thanks in advance
My regards

1) Application Rules (Predefined FTP Client modified)


2) Settings for each rule in order as above


3) Blocking events



Thanks for the additonal information on your blocks. Couple of things to do.

  1. Are you using the Comodo Web Browser rules for Firefox. The “allow passive FTP” rule is also missing there also, and needs to be added. This is the port 21 block
  2. Take a look at your global rules. Do you have a “block all in/out” type rule there? Add an “Allow TCP in from port 20” rule ahead of it.

Siber i think you added the rules to the application. You need to go under the global rules tab and add them there.

Hi sded,

Thanks for reply and for creating “the Major FTP Topic” thread

The only thing I’ve added was 1 (one) Global “20”-Rule as advised here and in your new topic:
“allow/TCP/IN/ANY/ANY/20/ANY” ahead of the block and log."
My other App Rules for FTP remain as it was posted here.
And I am able to connect.
To tell the truth I am not quite understand this statement:
“You will need to do this for every inbound connection allowed by the application rules.”
But I hope I’ll learn :slight_smile:
I am not using browser FTP client and that was my another surprise when I saw 21 blocking for Ffox. But now I don’ see any, despite no other changes in addition to mentioned one were made.

My kind regards

the Preview still not working… but it is a temporary thing. Moderator(s) are informed.

That statement really had nothing to do with FTP. We just need to start reminding users that for every application ruleset that requires an inbound connection, they need to add the rule again in the global rules because of the “block all” there. Some of us really don’t use the global rules, but we need to sort out the usage a little better for those who do. Glad everything is working for you; now on to the next final next week! Don’t forget to export your settings.
Regards; Ed.

Hi Coolio10,

Thank you for response.
Sorry for the delay… just got busy … usually/sometimes/occasionally…
I am not very rude :SMLR

SiberLynx (:WAV)