Frustrated getting Teamviewer rules to work

Well I use it to help friends but some of them use Comodo and want me to do remote support when they are not there and is really frustrating to get a connection due to Comodo blocking the application even though at every pop up my friend selects Trusted Application. Both he and I are using Comodo 3.9.95478.509 and it is impossible to get this application to connect to his computer with no one there and Comodo running. What the heck is needed to get Comodo to play nice and actually allow this application to work? Firewall and Defense+ are set to safe on both of our computers.

I get frustrated with Comodo when one constantly tells it that Teamviewer is a trusted application and it still does not allow it to function properly. How does one allow port 5938 to be used by Teamviewer on the friend’s computer without him having to constantly answer prompts from Comodo re Teamviewer?

Hi frustrated.

I don’t use Teamviewer, however, the Teamviewer website makes a comment that I find a little alarming:

The major difficulties in using remote control software are firewalls and blocked ports, as well as NAT routing for local IP addresses. If you use TeamViewer you don't have to worry about firewalls: TeamViewer will find a route to your partner.

To my mind that suggests a serious security issue. However, if you wish to use this software you will have to perform some detailed analysis of it’s communication pathways.

The first thing I’d suggest is making sure the Teamviewer application has an entry in the Firewall Application rules list and that you enable logging. Dependant upon the definition of the statement above, you should get some entries in the log, which wil show which ports the application requires.

Use that as a starting point. Alternatively, you could consider something like Hamachi for your needs.

Well that reasoning would also eliminate LogmeIn as well as GotToMyPC since they also do the same thing i.e. nat traversal and blocked or stealthed ports.

The problem with Hiimachi is that it is geared more towards people with a technical background and I am helping people who have problems with doing simple tasks. Hamachi requires installing the app, using it and then uninstalling it even for a one time use.

With Teamviewer one can use the app once and there is no need to install it.

Will see if I can find the ports that Teamviewer use and hopefully set a rule in Comodo.

Which Team Viewer module do your remote friends have installed?

Do to unattended remote connections, they need to install the Team Viewer Host.

And you will need to open the required ports in Firewall Global Rules, to allow for unsolicited incoming connections.
When you select allow remember or trusted it makes Application Rules, and that is fine.
Application Rules Team Viewer Trusted will allow all in and out for team viewer, But your unsolicited incoming attempts bounce off of the Global Rules or Router.
Think of Global Rules as your outer shell, you need to open a hole to even get to where the Application Rules come into play.

With this info and the TViewer help manual you should be able to sort this out.

Hope this helps, post back.


Hey guys,
I use TeamViewer many times a week, most to help my family with computer problems.

Since Comodo is the first full 64bit software, and indeed has a good control, I am “adicted” to this software.

So with TeamViewer, I only got one problem remaining: DirectIn Connection.

Therefore, TV needs two ports opened 80 and 5938. So i did it in my Router and tried in Comodo. But whatever I do, the only way to get a positiv result vom TV is to shut the firewall OFF.

See the pic for what I need, port 80 was already there, 5938 was added by me. What else is cutting DierctIn down?

I have run TeamViewer as a Trusted application with no issues whatsoever.

Did you tested DirectIn too? Cause thats the only thing that doesnt work!!! The rest runs great!