Frostwire won't load [Resolved]

When I double click the Frostwire icon it tells me that it’s unable to start because of a firewall blocking it’s access or a loopback connection but my Comodo is set to allow FW access?

It also gives me the same error when Comodo is set to allow all.

Allow All is equivalent to disabling the firewall itself. After you activated that option, did you try to restart Frostwire to see if it works again?

Also, it’s better that you enable both skip loopback checks in Security > Advanced > Miscellaneous > Configure (unless you run a proxy server).

Yes I did restart Frostwire, also both loopback checks are now skipped.

Do you think my router may of something to do with it? I have a bt voyager 2091

give us some more info like Did it work before you installed CPF. Did you use any firewalls earlier? Before installing CPF did you have any trouble with the router?

I used Sygate Pro before and it didn’t work when I had that installed, there hasn’t been any problems with the router as far as I know.

Screenshots of AM and NM rules and a sample of your log would help to see if anything’s blocked.

Ok, whats AM/NM?

These are abbreviations to help us through the day… :wink:

AM = Application Monitor (also sometimes “AppMon”)

NM = Network Monitor (or NetMon)

LM

Here we go:


http://img505.imageshack.us/img505/5178/20070618175118az8.th.png


http://img231.imageshack.us/img231/2327/20070618175137qz0.th.png

There is nothing in the logs section for Frostwire because it cannot start, I get the loopback message at the splash screen.

Frostwire is a p2p - I’m assuming it also requires an opened port so you have to create a NM rule with something like this: https://forums.comodo.com/help/help_getting_comodo_to_allow_utorrent_resolved-t8049.0.html;msg58392#msg58392

What’s strange is that when you CFP’s Security Level to Allow All and restarted Frostwire, it still didn’t go through. It’s most likely something else. You may have to clean uninstall and reinstall CFP in safe mode to avoid program conflicts.

I did do a clean install of CPF but still now joy. I am wondering if it could be due to an XP update?

That I don’t know, but you stated this earlier:

When you uninstalled Sygate and just before you installed CFP, during this time did you try to see if Frostwire would work?

Well I use Limewire and I don’t have any specific opened ports! Check whether you have Windows firewall enabled (if so disable it) Kill both cpf.exe (click exit) and cndagent.exe And try to connect. And if it still doesn’t connect the problem is not with the firewall!

you mentioned that it didn’t work with Sygate Pro as well! Now that’s a concern! Cuz it seems that it’s not a problem with the firewall!

I killed cpf.exe & cndagent.exe and that doesn’t make a difference. Windows firewall isn’t on either.

I just thought, I remember installing Apache a while back and I wasn’t able to access my local pages by typing localhost, I had to type 172.0.0.1.

Could be a DNS issue:
** FAQs/Threads - Read Me First **:

[b]Clear DNS Cache[/b] https://forums.comodo.com/index.php/topic,719.0.html

http://www.updatexp.com/dns-windows-xp.html

Well I have tried flushing DNS but that doesn’t do anything.

I have also had a browse through those links.

If I ping localhost I get a request time out, that isn’t sposed to happen is it?

Indeed…something must be up if you didn’t receive a reply… What about pinging 127.0.0.1?

Is Frostwire the only program with internet connection problems?

Here’s a link that seems to fit your case:
http://www.computing.net/windows2000/wwwboard/forum/38397.html

Pinging 127.0.0.1 is dead as well. Other things work fine like games, MSN etc. I just tried the following:

Bearshare - did not connect
Bitcomet - Was able to download
eMule - Was able to download.

That was a good link you gave me Soya, I will try and uninstall/reinstall the TCP/IP protocol suite and see if that helps, will report back soon.

The Microsoft method: http://support.microsoft.com/default.aspx?scid=kb;en-us;299357

Yay it worked! I reset the stack and all works well again. Firefox actually opens really quickly again as well, it used to take ages to open as did Thunderbird but everything is so much quicker now!

Thanks to all that helped.