FrontPage 2003: connection timed out

I have your fine Comodo Internet Security, I like it but I have a problem with FrontPage 2003. When I try to update my website I have to disable the firewall module, because otherwise FrontPage wait a long time then show error “425 unabe to build data connection: connection timed out”.
In the firewall network list FrontPage is a “safe application”, but it is not enough.
Some suggestion please?
Thank you very much

Welcome to the forum mlolcu :slight_smile:

Can you please post a screenshot of Firewall events.

here is

[attachment deleted by admin]

Had you tried to update your website in the time that the log shows.

All I have found is your error is related to FTP and there are not blocks of this sort showing in the event log.

I do not saw events about FrontPage in the firewall event list and FrontPage is a safe application.
As I said, it is strange, because I have to disable forewall module when I have to update my website with FrontPage.

[attachment deleted by admin]

Could you check your Global Rules and if you have a Block rule at the bottom change it to log.

Then try again there should be some entries after this.

Dennis

sorry Dennis,
nothing to do.
If I reinstall Comodo could find a different situation?

Could you please post a screenshot of your Global rules.

I have asked for help.

Dennis

I am sorry for rules in italian

[attachment deleted by admin]

Probably using Active FTP here.

There are two options

  1. you change frontpage so it used “Passive/PASV” FTP
  2. you have to allow incoming traffic from the FTP Server towards your system

a1)

a2)
Create a global rule like
Allow
TCP
IN
Source = IP FTP Server
Destination = Any
Source Port = 20
Destination Port = Any

And make sure it’s rule nr 1 (all the way on top, so no other rules can overrule/block).

Thank you very much for your attention.
I consider the option 2)
I know only one parameter to set FrontPage: “ftp://ftp.WebSiteName.it
I tryed PING either for www.WebSiteName.it and for ftp.WebSiteName.it and I got the same IP. I am not sure this IP is correct, because I made a global rule as you showed, but unfortunately without succes and without any log in firewall event list.

Is the Frontpage executable set to “Trusted Application”? in the Network Security Policy?

Yes

[attachment deleted by admin]

Can you post a new screenshot from the global rules?

Can you try to set the port to ANY ANY and check the “log” option also so you can see if there’s incoming traffic matching?

The IP also is used by ftp.slimsoftware.it and connects to an FTP server so it’s probably the right one.

I set the port to ANT ANY and checked “log” flag, but unfortunately therese is no log for the event and FrontPage replyes always:
425 unable to build data connection, connection timed out

I am sorry for the accident, Comodo is a great software, but only with FrontPage I have to disable it to be able to work. I suspect something was wrong at the first FrontPage activity and Comodo signed it as “not safe” in any way. Maybe I could reinstall Comodo?

thank you very much

Okay let’s switch the rule temp for the following.

Allow + log
TCP
IN
Source IP = ANY
Source port = 20
Destination = ANY
Destinatio port = any

See if that creates a log entry and makes FP work.

sorry, nothing to do.
Connection timed out for FrontPage and no log in firewall event list.

One more test then, switch 20 to ANY, test, this should log all traffic, including the FP session.

sorry, nothing to do, no connection and no log.
All is right if I disable firewall.