Fresh Install of ComoDo fs filter driver is not loaded


I just installed ComoDo on my Linux Mint 17 box and I don’t understand how to fix this issue with this filter driver.

filesystem filter driver is not loaded

So to fix that the program says to run:

/opt/COMODO/ (and than run)
/etc/init.d/cmdavd restart

I did that and rebooted my pc.

I’m still getting that the filter driver is not loaded when I launch the program.

How do I fix this?

Here, this should help you. It helped me.

Hope this helps

Thanks for the link-

I’m not very good with compiling.
I’m pretty sure that the driver.tar has to be compiled by reading a Install or ReadMe file.

The Install or ReadMe files are very hard to understand. Least they are for me.

I’ll give it a try and see if I can get it to work.
If not; maybe uninstall and than reinstall cav-linux–

I couldn’t install the filter drivers because I don’t understand the Install file that came each driver.
IMO the Install files are complicated.

I uninstall the program with:

sudo apt-get --purge remove cav-linux

I’ll try re-installing ComoDo again and hopefully a fresh install won’t give me the same issue.

Well a fresh installation made no difference and trying to understand the Install file only leaded to the compilation failure. :-
I ran this command but don’t understand why it failed or how to fix it.

make -C /lib/modules/`uname -r`/build M=`pwd` \

Is installing the avflt and redirfs the only way around this?

Is there anyone here running Linux that had success with this?
If so please enlighten me.- :slight_smile:

:wink: Great news guys!

ComoDo is working on my desktop with Linux Mint 17 Cinnamon and it’s also working on my friends Linux Mint 17 KDE desktop pc.- :slight_smile:

After I installed ComoDo I than install the 3 modules (driver.tar) by moving them.

sudo mv driver.tar /opt/COMODO/driver.tar

Than I changed directory-

cd /opt/COMODO

Than ran these 2 command but didn’t launch the program and restarted.

sudo ./
sudo /etc/init.d/cmdavd restart

Upon restart the Comodo data base took a while to update.
After looking around in Diagonostic’s for a few min’s all seemed set up correctly.
I ran the first scan and it’s running properly.

BTW Comodo in Linux is “cav-linux” which is dependent upon libssl0.9.8 which I had to go and download from Debian.

The dependency “libssl0.9.8” had to be installed with the dpkg command first before installing cav-linux.

That was a lot of work but it’s nice to have ComoDo working properly!