free firewall update hangs ""Copying cmdagent.exe"

Free firewall Update hanging on “Copying cmdagent.exe file” every time, on one of my identically-confgured computers. I’ve tried 6 times.

On the other one, the update from 5.5…1383 to 5.8…2124 (why such long version numbers?) went great.

Windows XP Pro sp3
No other software running other than Norton AntiVirus 2011/2012 (I upgraded between the start of this issue and now).

I can confirm that. On my XP SP3 laptop I aborted the update after more than an hour had passed and the updater was still copying cmdagent.exe and using 98% CPU in the proces. Tried again, same problem. Rebooted, tried again, same problem.

I was hoping for a new cmdagent which wouldn’t monopolise the CPU, but apparently it is not to be.

Unless anyone has a better idea, I think I’ll download the complete installer tomorrow and try it that way.

Please try right click Run as Adminstrator.

AS suggest here by Egemen;msg555230#msg555230

He posted an other possible workaround here

No such luck. The updater dies with a message that “the system can’t find the file.” It doesn’t say which file, so not very helpful.

Updates have been suspended.

They want to clear this issue you are having so you do not have to use workarounds.


Good news, Dennis. Thanks very much. I’ll give it another try tomorrow or the day after.