Framework dll issue [Resolved]

I can’t up uninstall or upgrade CPF Pro. When I try to uninstall it, it tells me that it can’t find framework.dll; however, as you can see in the attachment, the framework is there. I found a topic on this in the forum with a solution. Which was a framework.dll file to download and copy to the folder it belongs in. Unfortunately, that didn’t solve my problem. Does anybody have any additional solutions to this problem?

[attachment deleted by admin]

Well, that didn’t help. The zip file was not available. It just took me to a page and showed me the link path in red, which could not be clicked on.

What about using Revo Uninstaller, would that work? If so how would I uninstall it safely. ???

Link works for me. Simply go to the main help page for Comodo 3.0 and look under important topics. You can try Revo but Revo only works if the program your trying to uninstall has a good uninstaller.

The link to the topic worked just fine. However, in order to uninstall this I had to download a file from here:

That was the link that isn’t working for me.

Rapidshare link works for me. Do you have some sort of pop up blocker?

Yes. Disabled it, and enabled Java and Javascript, and closed my firewall, and antivirus to see if that would make a difference. It didn’t.

Try IE if your using FF. Dont know what to tell you. 3 pc’s I tried and link works. What about copying and pasting the link into your address bar.

Tried all of your suggestions. Nothing worked. It still takes me to a page to register for their service. It doesn’t give me a download file.

Did you click on free or premium? There is also a file on the bottom of that first post. Click on the attachment.

Oh, so I have to sign up to download the file? Well, can I use the free service to download it?

NONONONO. I never said sign up. Click on free or else click on the zip file on the bottom of USSS post. It says zip file with an attachment. Geezzzz.

When you click on the rapidshare link it brings you to a page to download the file via a premium service or free. Click free.

OH! Now I get it! Well, that was a little confusing. That link was in little tiny type, and that threw me off. OK, now I’ll see if I can do this. Gee I hope I don’t blow up my computer. :slight_smile:

Again your not understanding. The link you posted brings you to the rapidshare site. The download zip file is on the bottom of the post but not for rapidshare.

Yeah, I got it. It is on my computer now. However, this does not solve my uninstall problem. I can’t uninstall it, not even in safe mode. This zip file is for using after you uninstall it. I tried Revo Uninstaller, but you were right it didn’t work for this problem. I tried another uninstaller that I have, and it reads, “Invalid Uninstall Link”. I try using Windows add and remove programs, and it says that Comodo isn’t even installed on my computer. I added two additional attachments that may shed some light on the subject.

[attachment deleted by admin]

You need to follow all those steps in USSS posts. Dont just try to use the batch file.

Yes, I know and step 3 of those instructions reads:

3. Open your third-party uninstallation tool (or Control Panel > Add/Remove Programs) and run it as you would normally uninstall any application.

I can not do this. I tried doing it that way, and it said it was not there, and may have been uninstalled. Which, it has not been.

Try going to C:\Program Files\Comodo\Firewall

Double click on the cfpconfg.exe file to see if that puts it in add/remove programs or try the repair file.



I did that. The attachment is what happened when I did that.

Yes, it is in the add/remove programs and when I tried using that I got a popup that said the Firewall was already uninstalled. What repair file are you talking about? What is it called?

[attachment deleted by admin]