FR: add an "Install with Secure" and "Install with Default" settings

I’d prefer an option to choose between these settings, as the default installation is not safe enough for me.