Foxit reader 3 continuously asks for permissions

Hello folks,

Ever since upgrading to foxit reader 3 when defence+ is in Safe Mode I always get a series of prompts when trying to open a PDF or just the reader directly. If I put CIS (.439) in Clean PC Mode or Training Mode it loads but it doesn’t seem to remember the settings.

I am running XP Pro SP3 in a limited user account (the same occurs with admin privileges).

This is very annoying has anyone else seen this problem/know how to fix it.

Sandman

I have foxit 3 with XP SP2. But nothing abnormal is observed.

Normally we will get more alerts in Safe Mode as CIS will check all the activities, assuming that the programmes are ‘not safe’. To avoid such annoyance you may add Foxit as a ‘trusted application’ in Defence+, which I think will remove the pop ups in ‘Safe Mode’ also.

Unfortunately that doesn’t work, as I have already tried that as well as setting custom and giving allow acess to everything.

Sandman

OK I seem to have fixed it.

  1. I uninstalled Foxit reader
  2. manually deleted all entries relating to it in the Defense+ settings and Firewall settings, purged both of those.
  3. reinstalled foxit reader.
  4. Added Foxit reader and all files in its plugin directory to my own safe files
  5. Set defense+ to training mode,
  6. launched foxit reader, closed it.
  7. Set D+ to Safe mode
  8. relaunched Foxit reader and this time no problem

I’m not sure exactly which of those actions solved the problem but one of them seems to have.

Sandman

Hi Sandman,

You can treat Foxit reader as a Trusted Application when you receive a Defense+ Alert. This will give Foxit reader full access rights, and you will only get one pop up. :slight_smile:

Cheers,
Josh