Forgetfull Firewall

Running CIS Firewall (only) 3.5.57173.439 on Win XP SP3. I’m running utorrent from a non-system disk as a portable application. This disk is encrypted at boot time (inaccessable). I’ve defined a p2p predefined firewall profile and added it to utorrent in the application rules. This works fine till re-boot, then CIS starts giving warnings on the startup of utorrent, even though the apllication profile rule is still there and correct! The workaround, but annoying, is to delete the application and add it again…

It would be great if something can be done about CIS’s Alzheimer!

If this has already been signalled, than I’m sorry!

It’s not Alzheimers - it’s been designed that way deliberately. The key factor is that you are starting the application off a removable drive.

Comodo have taken the decision that no application started from a removable drive is to be considered trusted. This applies even if the application is question has a trusted policy. Their reasoning is that since the application is on a removable drive and that removable drive could be, and probably has been, attached to a PC that may not be protected by CIS, the trusted status can only be assigned on a per-session basis.

Yes, it’s a bit of a PITA - but it’s a logical and necessary one.

Ewen :slight_smile:

Hi Onofrio,

This issue was addressed before.

I think that panic was answering previosly as well and as experience sayis his answers always have reason.

At that stage that was considered and called a “bug”. Now we have more understanding of the matter.

But there are some tips that probably may help and make it a bit less annoying.

Have a look (link below) at creating permanent letters there for externals.
The only slight issue I had with that was - as soon as Purge performed - that’s where the rules are gone if drive(s) not attached currently. And there is no way to make differential purging (I mean exclude something from the list)
Keep in mind that I did not return to the problem since and what is written here is just from my memory.
So, please read if you have time and maybe some things will help


Well, it’s not a removable drive, it’s a partition on my (only) hard-disk. My system partition is only small and not encrypted. For reasons I leave up to you to appreciate, I don’t want uTorrent on this system partition, but rather on the encrypted partition, together with the rest of all the data. People have and will in the future, more and more, encrypt their harddisks. Also portable apps are more and more the way to go.

It could be an option to be turned on or off! Or enforce some MD5-sum checking for program files on “removable” drives… Apart from the time it takes, it’s no problem to verify whether the app is still, the same as the one I made the profile for… :-TU

It has a permanent drive-letter, that is after it is mounted… But I can change that and make it have a drive-letter before it is mounted…

EDIT: Well, this solved the problem… So I now allowed the Software to give the partition a drive-letter at boot, than CIS threats the whole thing as permanent… and problem solved… :BNC Thanks for the pointer!

You are welcome. :Beer I’m glad it helped Cheers!

Sorry, I misinterpreted your OP.

Ewen :slight_smile: