Forever updating

Some time ago I had the same problem, so I searched the forums but couldn’t find that topic again, it’s been a long time ^^"
So CIS is telling me there’s an update ready, I’m ok as usual and starts download, installing and then there’s the message saying “copying cmdagent.exe file” and there stays like forever; I thought it could take a long time so I cancelled and did the update before going to work, when I got back, it was still “copying”. 9hs is too much to me :wink:
Also noticed that it takes a lot of system resources since even GPU’s fan starts to go faster as CPU fan too.
Also, in the third attempt already, instead of cmdagent, the file being copied is cfp.exe and it takes forever and ever too.
I’ve tried killing those processes but it won’t help. I really wish to avoid uninstalling because all the “remember this and that” I have (sometimes games stays at black screen trying to connect to internet and it’s because CIS is asking me to allow it but can’t alt+tab back to allow so I’m stuck at black screen) so I would hope to a solution for this, I remember there was one but I can’t remember exactly what was it :frowning:

Hi welcome to the forums :slight_smile:

First I’d recommend trying the Diagnostics feature in the “More” tab. This will try to fix any errors in CIS that it finds.

If this doesn’t work, I’d export your configuration and just do a clean install. You can export your configuration using the option under the “More” tab.


I’m having the same problem exactly. I’ve tried to do the update at least a dozen times now and it just goes on for hours. Says it’s “copying cmdagent.exe file” or copying “cfpupdat.exe file” apparently perpetually. I won’t claim to have let it go on for 9 hours as you did, but have let it go for over 4 hours twice. I have no reason to believe it will ever finish. Diagnostics finds no problem with my installation. I’d like to know Why this is happening. Sure, I could uninstall then reinstall, but I don’t feel I should have to do that. And that wont tell me what the problem was in the first place.

I don’t know why this is happening but you could try the procedure I described in my previous post and see if hat fixes it or not.

Same problem here, except it hangs on the install_init.xml file. I’ve exported my configurations. I’ll give it another day and check to see if anyone knows what’s going on, then uninstall/reinstall.