Flash player install rehash [Solved]

I am trying to update Flash player and having a problem with doing so. I searched the forums and found this thread:
https://forums.comodo.com/bug-reports-cd/flash-player-install-problem-t90232.0.html;msg650319#msg650319

My problems are similar to that user’s problems and I saw the suggested answer. The thing is, I don’t have Dragon installed and I don’t know where to find privacy settings in the console. On top of that, I also found this thread, that seems to indicate the Dragon no longer has a way to change privacy settings.
https://forums.comodo.com/help-cd/settings-privacy-settings-t101252.0.html;msg734272#msg734272

So, it may not be much help to have Dragon. Is there something to fix this?
Mod edit: Added solved to the topic title, Captainsticks

Hi iowared,
Can you download and run the appropriate full installer from the link below?
Adobe Flash Player Distribution

Kind regards.

Thanks for the reply, captainsticks. I logged in as the admin on the computer and got a prompt to update Flash anyway. Too bad that didn’t happen before I went in circles last night trying to manually download and install the app.

This can be marked as solved.

You are welcome, I am glad to hear the issue is solved. :-TU

This can be marked as solved.
Done, thank you.