Fix the darn full-screen freeze already!

Where do I begin? I can’t stress enough just how many times I’ve forgotten to disable the HIPS/BB and ran a computer game. The game then switched to full screen and froze the whole computer because it triggered a HIPS popup alert.

When a game is run it normally switches to full-screen, and changes screen resolution. Next the game triggers a HIPS alert that displays a D+ popup which is waiting for user input in the background. This is the problem. The popup alert halts the execution of the app, but since the app is full-screen and/or different resolution, the popup alert is normally displayed off-screen, so there’s no easy way to respond to it. The whole screen is black. This means the computer is frozen until the popup times out. And normally a game will trigger multiple consecutive popups that increase the timeout to the number of popups multiplied by the timeout for a single popup. This can take up to 10 minutes or more before the PC becomes responsive again, and it is sometimes faster to just hard-reset the computer.

Yeah yeah, I know. Use the frigging game mode you n00b! Well, not quite! Just what the heck is wrong with game mode you ask? Everything! For starters it seems to automatically allow most alerts including some firewall events - of which there are many that I would not normally allow (I’ve had some applications bypass the firewall this way). As an addition I’d like to point out that all of us are only human beings. Yes, humans, people! And people are bound to forget things. A lot of times I simply forgot to activate it before double-clicking that icon on the desktop before realizing oh shi… BLACK SCREEN! And did I mention? Just as I forget to turn the game mode on I also forget to turn it back off once I’m done playing. Worse off, the game mode seems to persist over reboots.

So please make sure that HIPS alerts are displayed on-screen when a full-screen game is launched!

Related threads:
https://forums.comodo.com/news-announcements-feedback-cis/my-cis-wishlist-thread-t96812.0.html
https://forums.comodo.com/defense-sandbox-help-cis/comodo-freezes-my-entire-computer-when-starting-fullscreen-games-t88549.0.html


Please also consider voting in these other threads: [[url=https://forums.comodo.com/wishlist-cis/perapplication-sandbox-rules-more-options-t93177.0.html]Configurable sandbox[/url]] [[url=https://forums.comodo.com/wishlist-cis/fix-the-darn-fullscreen-freeze-already-t97376.0.html]Full screen freeze[/url]] [[url=https://forums.comodo.com/wishlist-cis/hips-process-policy-inheritance-t97373.0.html]HIPS Policy inheritance[/url]] [[url=https://forums.comodo.com/wishlist-cis/cis6-classify-files-by-path-not-file-hash-t97372.0.html]Classify by file path[/url]] [[url=https://forums.comodo.com/wishlist-cis/hack-tools-disable-av-unwanted-software-t97371.0.html]Hack tools[/url]] [[url=https://forums.comodo.com/wishlist-cis/cloud-lookup-disable-safe-files-t97374.0.html]Cloud lookup control[/url]] [[url=https://forums.comodo.com/empty-t29948.0.html]Better SVCHOST handling[/url]] [[url=https://forums.comodo.com/empty-t69214.0.html]Firewall WHOIS[/url]] [[url=https://forums.comodo.com/wishlist-cis/configurable-sound-options-with-poll-t76512.0.html]Configurable sounds[/url]]

I completely agree. It’s a total PITA when I go to play a game, and my computer becomes entirely unusable. I used to be able to get out of it in CIS 3.x or 4.x by doing Ctrl+Alt+Del to get to that Lock/Log Out screen, but with the latest versions, even my KEYBOARD locks up. I could also RDP in from another box and accept the dialog, but now that just hangs, times out, and disconnects me. I end up having to wait until the dialog expires before I can do anything, and, honestly, it’s unacceptable behavior on the part of CIS; it’s somewhat tolerable in Safe Mode, but forget about Paranoid Mode.

From what I’ve read, Game Mode is way too lenient, and Training Mode is undesireable because it applies to the entire system, not just the game I want to play and its child processes. I should also be prompted to classify an unknown application BEFORE it runs. These are all things that Tiny Personal Firewall did right, and it’s really disappointing that no other HIPS software has been able to duplicate its performance, functionality, and ease of use…

I really don’t see why this is STILL a problem after FIVE YEARS (more, probably). I would start paying for CIS if Comodo’s project leads would get their act together.

Signed up just because I agree so much

This bug has been around like forever, it’s stupid, it’s critical, it’s easy to fix and it should be of some priority, which it clearly isn’t right now.

+1 Agree, I too sometime find this one a headache

Having installed Comodo Firewall again yesterday, I was very impressed by the overall improvements made in functioning and design since I last used it in 2008. Sadly, I came up against this black screen of death issue when trying to enter full screen mode, or alt-tab in full screen mode. I tried everything I could think of and after 10-12 hard reboots, I finally had to give up on using Comodo Firewall. I’ve read all of the forum posts on this subject and just wanted to add that I am disappointed no solution or fix has come of this issue since it first started happening in 2009. I can only conclude that nothing will ever be done to fix this problem which, for some of us at least, makes the product unusable.

===========

[edit] Nov. 14. I wanted to add that I reinstalled CFW and put Defense > HIPs & Firewall both into training mode and ran my full screen game for 15 minutes, quit game, restored HIPS & Firewall to safe mode, ran game again and all has been well. This would be a hassle to do if I played a lot of game using full screen, so I still think a fix is in order. Really, all it would take would be for CFW to force alerts to go to top of screen, at least when in full screen mode.

Getting games to run in paranoid mode is a challenge. Depending on the game, I’ll hit the windows key, ctl-alt-del, anything to get the game to the background so that I can see the pop-up message. But when I get to the point when the screen goes black and nothing happens when pressing keys, I set “Interprocess Memory Accesses” for the game to “allow”. Unfortunately, I can’t narrow down which process needs the access. I would think that it’s explorer but that doesn’t work. Allow all is my only solution at this time.