Firewall's Custom Policy acts like Block All ( 32-bit) [Resolved]


1. CPU (32 bit or 64 bit)


2. Operating System information (including Service Pack Version)

Windows XP Professional SP2

3. Actively-running security and utility applications

CFP 3, Avira Free 7, CMF 2, PeerGuardian 2, Sandboxie 3.21

4. Specific symptoms of the bug, and steps you can take to reproduce it.

When using Custom Policy for the Firewall, it acts like I’m using Block All, so all traffic gets blocked.

5. Specific steps you have taken to try to resolve it.

I’ve tried a reboot, doesn’t work. Only way to resolve at the moment is to disable the firewall. Haven’t tried to do a complete uninstall.

6. Brief description of your Defense+ and Firewall+ mode (Custom, Train with safe) plus mention if you modified any setting in ADVANCED section of D+ and F+

Firewall’s set to Custom Policy (it’s disabled at the moment, but that’s what I used when the bug occured). For alerts I use Very High. Alerts enabled for TCP, UDP and ICMP. Everything in Attack Detection Settings->Misc. enabled.
Defense+ set to Paranoid Mode. Everything enabled in Monitor Settings, also using Block all the unknown requests if the application is closed.


This was an issue in the previous beta, have you tried it with this unchecked?
see here


Thanks for your reply John.
I don’t see why that would affect the Firewall, but I’ll try and see if it works.


EDIT: Seems like it didn’t work…

It’s always best to try the simplest things first!

I’ll think about this some more and do some searching for you as well.


I have the same settings as you have in Firewall & Defence+ and also using Block all the unknown requests if the application is closed.
The only differences are Windows XP Home edition.
AVG Antivirus 7.5, Sandboxie 3.21 and AdSubtract Pro.
No problems with firewall blocking.

Oh well, funny thing is it just happend today, been working fine before.
But anyways, I hate Microsoft, so here’s the only (Windows) services that’s running (the rest is either disabled or set to manual):
Event Log
Plug and Play
Remote Procedure Call (RPC)
Windows Audio
Windows Management Instrumentation

I know CFP needs (?) Terminal Services, but it has worked fine until today. DHCP Client not needed since I’m using a router, and also for DNS Client, I’m using another DNS Server than Windows defualt one.
Bit off-topic, but I think that I owned Safe Mode ;D


Even though OT, according to egemen, Terminal Services is not needed by CFP. You may need it for other things such as fast user switching, etc. but it is not a prereq for CFP.


I apologize for not thinking of this sooner than this morning thinking about differences between Home XP and Professional, and I remember what I did 17 days ago when I installed CPF3 latest version I set Firewall at Custom Policy(Alert Highest Level) Defence+ at Paranoid.

But I also deleted all preset Rules(Apart from Comodo’s) and ticked box for Enable alerts for Loopback requests.
(This can cause problems)
Sorry for not thinking of this sooner.

Okay, now I’ve fixed the problem!
Seems that somehow, my MAC adress was changed from 0A-0A-0A-0A-0A-0A (it’s not fake :P), so I couldn’t connect to the Internet, but when I changed back to 0A-0A-0A-0A-0A-0A it worked again. Anyways, thanks for your help guys!
I’ll go ahead and close this now that I’ve solved this problem myself, and it wasn’t really a bug.