firewall

how i change settings in comodo firewall for
dont share files in the Lan

Your >computer< should get set to a state, where it doesnt accept requests from the “outside”. Make sure that this is the case.

For cases where you computer might get instructed by the current user to send files to the “lan”, you must check what you need to block “outgoing”.

The thing is:
There are many ways to “share” files. And some of these ways may include the maximum amount of possible ports.

The second step in >the firewall< is, blocking requests from the “outside”.
Use the stealth port wizard setting 3.
“Hide me from everyone”.
This will create a rule in global rules, “Block IP in any any”.
That way you dont get asked for unrequested ingoing attempts.

But you should disable services for “sharing” anyway (especially remote desktop and alike).

If you can be more specific about the cases you are thinking about, you will get more specific answers.