Firewall won't install, "This Installation Does Not Support the Target Platform"


I’ve searched the board and found some related topics but I didn’t find quite what I needed.

My cousin’s computer was running slowly and she asked me to fix it for her. I went through and did some cleaning and it’s running fine now. I installed Avira AntiVir and tried to install Comodo thrice but got this, “This Installation Does Not Support the Target Platform.”

One of the posts here that I read said it was something to do with it being a 64bit Vista machine. This OS is the 64 bit. Is there another version of Comodo I can run on this?

I went to Major Geeks (How To Protect Yourself From Malware! | MajorGeeks.Com Support Forums) and read their Protect Yourself from Malware post. I’ve tried to install 3 different firewalls and they’ve all aborted. Is there a firewall that works with 64 bit Vista?

Am I doing something wrong? I deactivated Windows Firewall before attempting to install the firewalls. Then I reactivated it & tried to install. Rebooted, deactivated it and tried to install Comodo again…all failed.

AMD Athlon 64x2 dual core 2.8Ghz, 4GB Ram, Vista Home Premium SP2

Thanks for the help!
Need any more info?

Try downloading from Firewall Download | Best Firewall Security software for Windows and make sure to change to the dropdown box to the x64 version.

Thank you, Eric!!

Sorry, about posting in the wrong place.

Np. Moving when needed is one of the things to do for us. The Comodo Forums are quite big; sometimes people get overwhelmed by the sheer choice of boards. :slight_smile: