Firewall will not update

When I click “check for updates” nothing happens.

Running firewall and D+ only.

My version is 5.3.181415.1237

Looking at preferences>update the “enable” box is checked and the url is

Putting that in my browser brings a 404 not found

How can I fix this?

Hi Stanr. If it is a 32bit system I would try replacing the cfpudat.exe file in Program files, Comodo, Comodo Internet Securty folder and also the repair folder with this one here supplyed by Dennis. Good luck

Thanks for the reply captain.

I should have said it’s win 7 - 64 bit.

Hi again. It is noted here that the 32bit replacement file did work with 64bit, that is up to you if you want to try. If that fails maybe a fresh install of the latest version is worth thinking about. V5.3 did have some update issues, but this file cured quite a number of them. Hope this helps. Kind regards.

I uninstalled v5.3.xx and installed the latest version 5.4.xx and I still can’t check for updates.

When I click check for updates nothing happens just as it did under the previous version.

Anyone got any ideas why this won’t work.


May be left overs of previously installed security programs are in the way. Try using removal tools for those programs. Here is a list of removal tools for common av programs: ESET Knowledgebase .

Otherwise do a Google search with terms “removal tool” and * name of product or vendor*.

The only other security program I’ve had on this computer was Norton and that was removed long ago.

When I first installed Comodo a couple of months ago it auto updated then stopped and hasn’t worked since. I didn’t even know that there was a new version as I had it set for what I thought was automatic update.

Please consider to run the Norton removal tool just to be sure.

I ran into some serious trouble with CIS (firewall & defense+ only, I didn’t need the AV). The update icon kept appearing. When I clicked on it I was informed that a new version was ready for install but clicking on the icon did nothing. I did this numerous times to no avail. So I manually downloaded the newest 64bit version from your download section. Ran the installer and would get a error message stating that my current version was incompatible what ever that is supposed to mean. Your new installer didn’t recognize my old version I guess. So I uninstalled Comodo and then ran the newest 64bit installer. I now can not get CIS to install at all! I keep getting an error message. On the safe side I did run full malware scans (Panda Cloud Pro, Immunet Protect Free, Malwarebytes). They all came up clean so it’s not a malware issue. So I’m back to using the ■■■■■■ Windows Firewall until I find a replacement that will work as wonderfully as your product did. As in past tense. Bummer! Thought I should give you guys a heads up on this. If you guys can fix this incompatibility issue, or what ever it is, I certainly would love to reinstall. OS: Windows 7 Ultimate 64bit SP1

Hi Ritchie. Sorry to hear of your problems. I would consider giving this tool a go and then try reinstall. Good luck
Hi Stanr. It might even be worth yourself giving this tool a try then reinstall, just in case whatever was causing issues in your old version wasn’t removed cleanly and is still present. Good luck.

Thanks captainsticks.

Unfortunately Comodo was the cause some major issues. I have been having some problems for quite a while, start up errors, shut down hangs, programs failing to start properly, etc. and couldn’t quite figure out what the cause was. In the end Comodo D+ completely failed.

I removed Comodo and all the aforesaid problems went away. For now I’m using WIN 7 firewall until I’m sure all the issues I had before are resolved.

I’ll run the programs you suggested and see what they find. However, I will have to think about reinstalling Comodo. As of right now I am enjoying my system not throwing errors, even though I have an uneasy feeling without Comodo. I’ve been using Comodo for a number of years.

Thanks again for your time and assistance.

I just didn’t feel comfortable with using the Windows firewall alone. After much thought I elected to do a fresh install of Windows 7 and removed all the junk that comes with a restore to factory settings, which included a Norton trial. Ran the Norton removal tool and reinstalled all of my software and updated Windows 7.

It has taken me four days to get everything back to normal. Other then a system freeze after installing Comodo, a reboot seems to have fixed that problem. I’m running Comodo in “Training Mode” for a while and things seem to be working again. I must admit that I have created a complete partition image just i case I have a problem. The image I had included whatever made Comodo misbehave.

Tried the Comodo Update and it checked for one. Since I have the latest version installed it didn’t require an update.

Please mark this issue as resolved for now.

Thanks to everyone who replied, I do appreciate your time and effort.