Firewall Will NOT Install; Message Says it's Already Installed

Long story short, I had to do a system restore because of software install conflicts involving CFP and Roxio CD/DVD Creator. The restore did not include an installed CFP. However, after the restore, when I attempt to reinstall CFP, I get a message that the program is already install and would I like to reinstall. I confirm, then nothing else happens. I’m sure there must be registry entries that are indicating to Comodo’s install routine that the program in installed. I found several entires within the registry referring to CFP 3…276.

What do I need to delete from the registry that will allow Comodo to reinstall the Firewall.


SA Jack

Running: XP Home SP2, Avast AV, Windows Defender, Windows Firewall (not by choice).


Try the file that I’ve attached. It’s a simple batch file that’ll remove all entries by Comodo Firewall Pro 3.
If you want to know which entries that’s removed, open the batch file with notepad.
Yeah, I know common sense tells you not to download files with that small size, but it’s much faster than doing it manually :stuck_out_tongue:


[attachment deleted by admin]

Yesterday, I posted a set of comprehensive uninstallation instructions, which I modified earlier today.


Ragwing’s BAT file might very well do the trick for you without having to go through all the steps in my post. Try his fix first.

Between two registry tools, RegSupreme Pro and jv16 PowerTools, I found literally hundreds of registry entries left behind by Comodo (, but I hope my situation was an isolated case. Either way, it looks like Ragwing’s fix contains all of the registry keys I’ve listed and perhaps a few more.

Be sure to post back and let us know how it went.


Great News, the .BAT file worked and allowed the installation of the Firewall. Thank you very much. I have one additional issue that I think is associated with Windows and not with Comodo. Since my last system restore, Windows security did not identify Avast as a trusted Anti virus. To get rid of the balloon, I needed to indicate that Windows did not have to monitor the AV status. After installing Comodo Firewall, Windows security gave the same message as not recognizing it. Again, I’m having to indicate I’m monitoring the Firewall.

Is there a download that will refresh the approved list of AV and FW programs so Windows security won’t flag this a a problem?

Also, I found it unusual that it took the FW so long to learn after installation. I installed using all default settings. Nearly 10-minutes of learning along with a very large number of Defense+ warnings. After things quited down, I checked to see how many pending files needed my attention. There were nearly 2,900 files. A good portion were able to be purged because they appear to be referencing the last good installation (these files probably piled up during my futile attempts to fix conflicts when attempting to reload Roxio CD/DVD Creator).

Thanks again for your help.

Hello SA Jack

Try this fix posted by USSS on the forum.


follow these steps (courtesy of forum member “pandlouk”):
a.  At the command line of Windows XP  [Start > Run] enter the command "CMD" (without the quotes) and press Enter.
b.  At the new Command Prompt window, type
     "NET STOP WINMGMT /Y" (without the quotes; there must be a space between WINMGMT and /Y) and press Enter. Then type "exit" end press Enter again.
c.  Go to the folder C:\WINDOWS\system32\wbem and delete the folder "Repository".
d.  Reboot. The Repository folder will be recreated automatically by the Security Center and will now display the correct information.

I finally found the batch file on the forum that will accomplish the same thing as JJasper suggested.

This is gibran’s Post #6 (“batch file”):;msg111499#msg111499

Either way should work.

The fix worked great. Windows Security is now recognizing both Comodo and Avast as my Antivirus & Firewall programs. Thanks.

I still don’t believe all is well with the Firewall. I’ve been running V3 since it first came out nearly a month ago. I’ve gone through …266, …268, …276 and never experienced the amount of learning that is going on from Defense+. All my installs have been with the suggested default settings with no application or global rule changes.

Most of the learning has to do with Avast, however, I’m noticing that both the learning and the defense alers reference c:\prog~1\alwil~1\ and that strikes me as not being right. Avast is locted in C:\Program Files\Awil Software\Avas4. I’m thinking that the learning and defense events are refering to another (possibly duplicate) Avast instatall. However, I can’t find any folder off the Root C:\ other than Program Files that begins with the letters Progra and ends with 1. Same goes for Awil Software.

Am I missing something here?

Thanks again to you and Ragwing for helping me get Comodo back up and running and Windows Security getting back on-track. -SA Jack

I stole them from your post and just added REG DELETE and /F myself (:SHY)

Yeah, I made it, so why wouldn’t it work? ;D

Sounds like it’s the 8.3 filename bug, thought it was fixed in


If it were a bug in 3.276, then I would think it should have shown itself right away. I’ve run .276 since it came out, and it has only been since the system restore and the reinstall (with your help) that the program is acting strange. I’ve never gotten warnings before when opening Task Manager or going to the Command Prompt. Do you think I should uninstall, use the .BAT file you sent me again, and do another install? Do you think that will get rid of everything associated with program?

Thanks Ragwing. -SA Jack

Hi Ragwing:
I went ahead and uninstalled CPF and ran the batch file you created to clear the registry. There are actually still a number of registry entries referring to CPF, but I don’t know if I should delete them or not. I did reinstall with the original posting of .276 when it first came out. At first, it acted well, it seemed to remember my responses to what I consider normal warnings (as it learns things). But within a short period of time, it started asking about everything, from activating screensaver, logging off, etc. I attempted to open MS Outlook 2000 and I got an error message that would not allow it to open. Assuming Outlook was corrupt, I ran an MS repair and was able to get it running. Then this morning, I went into Outlook again and got the same error. This time I got warning after warning from FPF regarding the .exe file to open Outlook. The warnings would not stop, so I exited CPF, and Outlook ran fine. I also notice that it spends a great deal of time learning about ashD in the Avast program. Nearly 5-minutes @ bootup this morning.

I’ve uninstalled it again. I know the Firewall is fine, because it ran so well prior to my system restore. I’ve created a restore point and want to go back into the registry and clean out any reference to CPF. Do you think that may help?

Thanks again. Take care. SA Jack

Could you please tell me which ones that’s left?

You could try that and see if it works.


SA Jack:

Consider reverting back to v.273.

I had to uninstall v.276 after I was unable to login using a fingerprint on my IBM ThinkPad T43. The system locked in a continuous loop that displayed a dialogue window, “Checking the status of the security chip…”

I tried everything, believe me. I had to troubleshoot the problem in Safe Mode, adding executables and DLLs as Trusted Applications. Even adding IBM and Lenovo as Trusted Vendors failed to resolve the bootup problem.

I’ll wait until the next release. Until then, v.276 is verboten on my T43. Of course, v.276 is working fine on my old desktop, except for the MSI Installer bug, which still persists.