firewall uninstall

Hey i´ve been browsing through the archive board, and found something related to my problem, but after reading it i can´t seem to fix my problem, so here goes:

I installed comodo and everything was OK, until sometime ago i kept getting a “unable to update” error. So i´ve tried to uninstal it and here´s the tricky part, i can´t. I went to add/remove programs and clicked on it and it didnt do anything, i try to go to comodo uninstal and it gives me an error “entry point _createframework@”
I´ve decided to get a new version and see it would repair itself, but i get a msg saying “you need to uninstall, do you want to uninstall now?” i click yes and nothing… =/

I tried using a uninstalling application and it gave me the same error.

I already have the registry cleaner tool i found in the forums, but i wanted to know exactly how to procede before i mess around with deleting stuff.

Thks in advance, and sorry if my solution is out there, but i didn´t find it =/

Try downloading Regcleaner and take out the Comodo keys. Take out the keys and now I think the installer should start. Does that work? Get it here: .