Firewall slow down only some applications

Hi all,

I’m a system administrator for a small business and planning to install Comodo Firewall V3 as personal firewall on all our PC.

It’s very powerful and secure, especially for Defence+, which is one feature that I have never seen before on other free (or pseudo-free) personal firewall.

I’m experiencing only one big trouble: it seem that comodo slow down only some kind of application when this access the network. While apps like thunderbird, firefox and many other tool (we use a lot of SNMP manager, remote VNC access to servers and so on) are not slow down, some application (eg. ConText, FreeCommander, CrossStudio) when used on remote files (across a samba share) slow down a lot (I mean… the stay locked even for nearly a second!!)

I have seen that ConText (which is a text editor) do a lot of samba access when you edit a file, the same when with FreeCommander you switch from a directory to another.

The environment is Windows XP SP2 (32bit) and my samba subnet has been added in “My Network Zone”.
All this applications has been added as “Trusted Application” to firewall/defence+ list.

Another strange thing is that those application slow down even if I shutdown the firewall (by setting it’s level as disable or by closing Comodo application). I have to uninstall and reboot Windows to have “faster” apps.

Any clue?
Do you think I’m missing something in my firewall setup?
Maybe this slow down is only due the fact that those application open a lot of TCP connection to access samba shares? If yes, why does firefox (which open a lot of TCP connection too to access complex web pages) is not affected by this slow down?
Is it possibile to avoid this?
Is it possibile to create a “white list” of application that “bypass” Comodo Firewall?

Thanks in advance and best regards,


Hi amonthedeamon

Welcome to the Comodo Forum

I think you need someone with a bit more technical knowledge than I have to help you with this. Maybe we can get someone now to look at this for you and see if it can be sorted out.


Thanks John!

Any clue?

Have you tried setting the affected applications as trusted applications for the firewall? You may want to look at what the D+ and Firewall logs show wrt those apps. That said, IME, disabling the component seems to fully clear out comodo interfearance in most apps.

I’ve seen programs make Samba share access slower, but not Comodo yet. Then again, I don’t use the above apps. What happens if you copy the file locally and edit?

Not sure if this may help but here is some useful info on slow browsing of network shares with samba:

The bit about old cached references slowing network browsing may also be useful.

This section about firewalls may also help:


Yes the affected application was added as “trusted application” in Comodo. BTW setting both Firewall and Defence+ as “Disable” does not change application behaviour. Only by un-installing Comodo (and rebooting the system, of course) those apps become fast as usual.

By using local file I cannot see any performance impact, so only remote editing (on samba share) are affected

Network browsing is not affected (as far as I can see) by this slow down. Anyway I tried to disable WebClient and nothing changed.

Regarding firewall ports: those samba share are on my trusted network and those applications are registred as “trusted application” so all the port should not be filtered (AFAIK)

Thanks for the suggestions anyway!



It slowed down some of my apps also. Hopefully next release will fix it.

I am having this same problem, the browsing of my network (samba and windows machines) is terribly slow.
Disabling does not have any effect. A reboot would probably help, but I want to be able to use comodo of course :slight_smile:

Is there any official bug report for this, is this at all a new bug since the latest versions? (i just started using comodo recently)

There has been an update. Use the updater and apply it.

Now this is interesting, because I only noticed my computer slowing down after this most recent update…

Which update? There was a small one today. Version 320.

I did the update and the probleems seems fixed!

that’s nice work, and speedy fixing! :slight_smile: