Firewall settings doesn't apply

Well, this bug has been here for long time. I won’t even bother to explain I’ll just provide reproduce and that’s it.


  1. install any version of Comodo Firewall
  2. change the ‘Firewall Behavior Settings’ to proper setting.
    (Custom Policy Mode, Disable: ‘create rules for safe applications’, Very High and check ‘Protect ARP Cache’)
  3. Install any application which requires an open port.
    (FTP server, Mirc, any P2P software, what ever)
  4. create an ‘Predefined Application Policy’ for the application (exactly what the application needs)
  5. create an application rule to ‘Network Security Policy’ with the ‘Predefined Application Policy’ you just created.
  6. restart the system
  7. when you login run the application & see does Firewall settings apply

Now, I have probably attempted pretty near everything that comodo firewall would actually apply the setting over restart of the system with no luck. I think this is something really minor on coding side. Like when comodo is started there’s somewhere an ‘apply the settings’ missing.

Only solution Open every reboot the comodo up on screen click either ‘predefined application Policies’ + Apply OR click the ‘Network Security Policy’ + Apply and after this everything works again flawless.

Personal stuff (Why it’s a problem):
I am rebooting a lot as I am doing a lot of hardware testing specifically drivers and other troubleshooting. Also I almost could bet my neck that this ‘bug’ is the thing which has been bothering my network connection on windows 7 start as if comodo would not apply and networking would of not been applied this would not allow svthost go through DNS correctly.

x83 board / 4Ghz Quad
Windows 7 x64 (absolute latest kernels / patches)
Comodo v4.1.150349.920

  • Have no other security application installed or applied
  • Connection is clean Ethernet (no modems or routers)
  • No windows firewalls / general Microsoft security policy is applied / No IPv6.

Darn, seems the earlier message which somehow accidentally vanished from my screen didn’t go waist, heh.

forum mod could delete the other post, if possible as it has only half the written info.

do you see this “bug” only since windows 7? for me is all working as expected, but i dont use windows 7.

and why should Mirc need an open port? you only need to allow outgoing traffic (as long as its not p2p maybe, or as you dont run a server).
then Mirc needs just the permission to connect TO adress and port, and you get the requested packets though.

I am using Windows 7 I have no clue of other systems.

I am asking here Comodo devel to reproduce the exact issue. Nothing more than reporting a bug.

depends where you use it, but who cares what program you use please stay on the subject. Even an ‘outgoing only’-rule would not apply aka. connecting to irc server. This is not about ‘ports’ it’s about COMODO Firewall applying settings after it has started on system start-up at all.

btw, it’s kinda funny this ‘outgoing’ thing.

I mean ‘Firefox’ or ‘Web Browsers’ works just fine from system start. :slight_smile:

Seems to somehow be only affecting the User created rules.