Firewall problem with exe modification [NBZ]

I use the manual mode of the firewall,
“sometimes” if I trust the internet access for an exe file… when the file is modified Comodo doesn’t notify me that the file was modified and give it full Internet access automatically using the rule created for the original version.

The bug/issue

  1. What you did: Update some executable files
  2. What actually happened or you actually saw: The firewall use the rules created for the original file
  3. What you expected to happen or see: A modified file notification and a trust connection request
  4. How you tried to fix it & what happened: The problems is casual and the file was secure however this behavior compromise the firewall reliability
  5. If its an application compatibility problem have you tried the application fixes here?: Isn’t compatibility problem
  6. Details & exact version of any application (execpt CIS) involved with download link:
  7. Whether you can make the problem happen again, and if so exact steps to make it happen: The problem is casual doesn’t happens every time
  8. Any other information (eg your guess regarding the cause, with reasons): I think is related with the file modification analysis policy

Files appended. (Please zip unless screenshots).

  1. Screenshots illustrating the bug: Cannot reproduce
  2. Screenshots of related CIS event logs and the Defense+ Active Processes List: No relevant event logged
  3. A CIS config report or file.: Irrelevant
  4. Crash or freeze dump file: NONE

Your set-up

  1. CIS version, AV database version & configuration used: CIS 5.3.176757.1236 AV Database 7522 Antivir+Firewall, Default config with “Notify All” Firewall policy
  2. a) Have you updated (without uninstall) from CIS 3 or 4: NO
    b) if so, have you tried a clean reinstall (without losing settings - if not please do)?: YES
  3. a) Have you imported a config from a previous version of CIS: NO
    b) if so, have U tried a standard config (without losing settings - if not please do)?: NO
  4. Have you made any other major changes to the default config? (eg ticked ‘block all unknown requests’, other egs here.): Notify All Internet Connection Request in firewall setting
  5. Defense+, Sandbox, Firewall & AV security levels: D+=Safe , Sandbox=Enabled , Firewall =Custom policy , AV =Stateful
  6. OS version, service pack, number of bits, UAC setting, & account type: Windows 7 x86 All service pack and updates installed, UAC enabled, admin account
  7. Other security and utility software installed: NO
  8. Virtual machine used (Please do NOT use Virtual box): NO

We would very much appreciate it if you would edit your first post to create an issue report in line with the bug forum guidelines and format here. You can copy and paste the format from this topic.

To understand the reasons why we ask you to follow these guidelines please see below.

Bugs/issues can be impossible or very time consuming to fix if developers don’t have enough information to reproduce them. Since CIS is free, development time is limited. So if you want your issue fixed, please use the format below to describe it.

To avoid clutter, issues not described in the format below your post will not be moved to the ‘moderator verified’ issues topic. This means that the developers may not look at it.

Best wishes and many thanks in anticipation



I have edited the post

Thanks :wink:

Could you please include the missing information in your first post.

  1. Defense+, Sandbox, Firewall & AV security levels: D+=Paranoid, Safe or Clean PC Mode , Sandbox=Enabled or Disabled , Firewall =Custom policy or Safe mode , AV = On Access or Stateful

Thank you



Thank you for your bug report in the required format.

Moved to verified.

Thank you