Firewall Pro Not Working - Need to reinstall - Cannot delete

I have Comodo Firewall Pro v. I’ve been having problems with it recently. Problems include:

  1. When I try to download anything and save it, I get the message: “You don’t have permission to save in this location. Contact the administrator to obtain permission.” After I disable Comodo, I am able to download normally.

  2. I attempt to update Comodo. I get the following message: “Error 112: Unable to copy file: cfpsbmit.exe. Please try again.”

I’m assuming there is a problem with Comodo. I would like to delete the program and reinstall. However, I cannot do this. When I go through Add/Remove (Running Vista), I get the message: “COMODO Firewall Pro Configurator has stopped working.” When I try to delete using the Comodo Uninstall program I get : "The procedure entry point_CreateFrameWork@0 could not be located in the dynamic link library framework.dll.

I just tried replacing framework.dll as in a Comodo forum post ( ) via download link: ( ). This did not work, but I have not rebooted yet.

I also ran the batch file ( ) as directed in Comodo forum posting ( ). After doing this, I could not connect to the internet. I assume this was due to registry changes. I could not fix this. As such, I used my restore point and am back to the initial problem. I think this batch file would have fixed things from the Comodo point though. When I tried to reinstall the firewall, it seemed to work right. If I try to reinstall currently, I get the message: "COMODO Firewall Pro is already installed on your system. Do you want to un-install it now? I select yes and get the “Configurator has stopped working message.”

I don’t know how to proceed at this point. Please help. Thanks for the advice and help. Chad

Hello Welcome to the forums :slight_smile:

Download the latest version of CFP3
Are you using a limited user account? An administrators user acount

I"m using Windows Vista. I only have 1 user account and it is an administrator account. I’ve downloaded the latest version of CFP3, but cannot install it as my computer says its already installed.


Does anyone have a suggestion? Thanks in advance for the help. Chad

Have you gone through all the registry entries in this post?

if that doesn’t help consider backing up all your data and re-installing Windows.

I ran the batch file as directed in this post:

As I stated in my initial post, after running the batch file I lost the ability to connect to the internet. Even after rebooting, I could not reconnect to the internet. I assume that the batch file changed registry data that altered network settings. I reversed the changes of the batch file by performing a system restore. But I’m back at square one. Still cannot remove or reinstall Comodo Firewall. Any other suggestions? Or have a suggestion on how not to loose the ability to connect to the internet after running the batch file? Thanks, Chad.

Anyone with similar probems or possible fix? Thanks. Chad

Maybe I missed it, but have you tried doing the uninstall from safe mode?

Yes. Have tried to uninstall via safe mode. Same result. Cannot reinstall under safemode either. I have gotten no where thus far. I have now deleted the entire “Comodo” directory. The Comodo uninstall file is gone. Comodo is “removed” from the programs list, but the new installation program still thinks its here. I’m sure I could fix that with the batch file, but again, this rendered my internet / network connection unusable. Is there perhaps one item to manually fix (instead of the batch file) that would make the new installation think that Comodo is gone? I don’t care if there are random files still present, because I’m going to reinstall anyway. Thanks for the help. Chad