Firewall prevents email from working

Several weeks after I downloaded Comodo v3, my email for, hotmail, and yahoo are all blocked. Email works again when I set the firewall security to “disabled.”

You’re accessing these email accounts through a browser, I assume?

Yes, all through the browser.

Hi puzzled

Try going to Firewall → advanced → network security policy. Find your browser listing and click on it and click edit. Select “use a predefined policy” and choose “browser” from the drop down list. This will give your browser outgoing permisssion for HTTP, FTP, and DNS.

Hop this works for you.


Thanks, John. Unfortunately, this does not work either - Firewall stills needs to be disabled for email using either Mozilla or IE to work (I could not even send this reply until firewall was disabled). The Mozilla message says " * If your computer or network is protected by a firewall or proxy, make surethat Firefox is permitted to access the Web."


Hello puzzled

Sorry that did not help. Try taking out of your “network security policy” “application rules” all instances of firefox (or whatever browser you are using), reboot and then start your browser again. When the first popup shows up (if it does), click on treat this application as – choose web browser. Hope this helps this time.


Hello peoples,

Same issue down this way also. I cannot log onto to hotmail without the infamous “disable”. I cannot send mail through my ISP email account. I had to disable to send this post. I can surf without no issues. Sites like are really tempremental. Some days i can access a used car search, some days it blocks me. I have tried the two suggestions above (from John) with no success. Im running :
AVG anti vir/ anti spyware
BO clean

Prior to the V3 install i was running ghostwall. Any response will be greatly appreciated.


PS. go boys n girls at comodo. Stella product with support network too match. May the masses grow.

I am in the same boat. I can not send email from MS Outlook when the firewall is enabled. I also can not access some https web sites (my banking site yes, but not my credit card site).

The strange part is that I installed v3 about a month ago and then all of a sudden these two changes happened.

I’ll look forward to future responses. Thanks.

Same with me, I was able to use email with v3 for several weeks, and then suddenly this issue occurs.

Here is another thing that you can try. Go to this post and follow the directions there.