Firewall popups disappear almost instantly

It’s already disabled.
I use the Firewall in Custom Ruleset mode, Auto-Sandbox disabled and HIPS disabled.

It’s difficult to test changes, because Comodo runs fine most of the time.

One last question before I will call it a bug and will ask you to file a bug report on it.

Please try adding the CIS installation folders to the AV exclusions of Avast and see if that helps or not.

OK, I’ll try adding the CIS installation folders to the AV exclusions of Avast but it will be difficult to see if it’s fixed, because the disappearing popups can happen several days in a week or take more than a month.

An intermittent problem. Yikes. Keep us posted though.

is this fixed?
cause I’m having this problem.
Product Version: 8.x [Latest One]
Popups disappear in micro seconds. ???

Are you running 8.1.0.4426? Is this an update or clean installation? It’s not on the release notes of the latest version.

I’m having the same problem but I think it only happens sometimes. Firewall worked fine for a week or so then this issue spontaneously appeared. This is clean install on W8.1. Happens for HIPS/firewall popups and also when I try to disable firewall. One more thing – running Avast free with Comodo firewall 8.1.0.4426. Added Comodo to exclusions for realtime protection and antivirus file shield. What’s the deal with Avast behavior blocker though? Where would I find that? Can’t seem to.

I didn’t know if the Avast AV had a behaviour blocker. When you can’t find it I assume it is not there. The reason for asking is that as a rule of thumb we advice against running two of the same security solutions at the same time: don’t run two firewalls, don’t run two AV’s , don’t run two behaviour blockers…etc…

Just rebooted and firewall back to normal. This popup issue was happening the other day and I didn’t think much of it until it started happening again. Will let you know if the problem returns.

Problem is back today…

I was able to solve the problem without rebooting … I just exited the firewall then reopened it.

Latest developments… firewall popups not working however HIPS popups are working. When I try to disable Firewall get the same popup disappearance error. Weird… What do you think ericjh?

What does Diagnostics tell us? Can post attach the Diagnostics report? Do you have other security programs installed that run in the background alongside CIS or CPF? Are you using the suite or the Firewall?

Same problem here first on win 8.1 now also on Win 10.

Any solution so far?

What I already did:

1-uninstall
2-Comodo cleanup
3- used regcleaners
4-mauanly removed some comodo leftovers.
5-reinstalled

The popus for firewall al only visable for 0.5 sec and then automaticly disappear.

I using latest version of CIS
HIPS popups are not showing at all. But I see CIS blocked them.

Thanks for any solution

I thought this bug would be gone after I updated to Windows 10, but it remains. I have no other AV active or installed and am forced to turn of various protection features because I can not chose what is allowed and what isn’t.
This is a serious issue.

  • Reinstalling doesn’t help. I even reinstalled windows 8.1 (Previous to upgrading), installed Comodo, worked fine for a while, then ■■■■. Popups shut down by themselves instantly again.

I wish I was able to properly debug this bug to find what causes it, but I am not up for making a completely clean install, reinstall comodo and attempt to keep track of every single change I do.
Perhaps an application that uses and updates some shared library without prompt causes the problem? I’ve got nothing installed that is supposed to interact with Comodo besides just regular windows interface/theme or/and hardware. Could running with two monitors have anything to do with it?

This bug remains a mystery with no permanent solution and has made comodo almost useless for up to or more than a year now.

&

Both of these post point to an issue with playing an alert sound when an alert is displayed, has anyone disabled the windows audio service or have the Lame ACM MP3 Codec installed? Also does the CIS option to play sound when an alert is shown enabled for those having this issue maybe try disabling this setting to see if it fixes the issue?

So where do I disable this warning sound? Windows setting or application setting?

Disabling sound in CIS: Play sound when an alert is shown.

To disable the Windows Audio Service go to Control Panel → Administrative Tools → Services. Now look up Windows Audio → select it → click on the right mouse button → a context menu screen shows → choose Properties → in the General tab stop the service and set the Startup type to manual.