firewall pop up screen for allowing items is blank

I have been running comodo firewall on my XP Pro machine for a few years now and never had any real issues or problems. However, when I turned that computer on today it started to do its updating to the newest version and then all of a sudden the screen that comes up to allow an item or cancel it was blank with just the option to allow or cancel visible.
During the time when the firewall was doing it’s update I suddenly got a screen for cpfconfg.exe and to put a disc into the drive - with the options to cancel, retry and something else. However, I have no idea why that screen would even come up and that is also when the blank comodo screen for allowing something became blank. I tried all 3 of the options for the cpfconfg.exe with nothing working - I even tried putting a disc into the cd drive and that did not help either. Eventually I had to just go to start and select to restart the computer in order to close both the comodo screen and the one about cpfconfg.exe (tried to end the task with task manager and that didn’t work either.

Anyway, after restarting the computer I had no internet connection any more and ipconfig /renew or any of the other options for ipconfig were of no help either. After looking for information on why I was getting a message that there was no media message in ipconfig (something like that) & trying all sorts of things I finally did a system restore to about a week ago (which was the last time I had that computer turned on) and I am now connected to the internet again and everything else is working just fine - except for the firewall. When I get the screen from Comodo for allowing something (have my settings set at safe) that screen is still blank and I have no idea what it is asking permission for. I eventually had to exit the program to stop those permission requests. I then tried to go to start programs and start the firewall again but all I get is a blank box.
I did copy the box using print screen but do not see an option to add that here so that you can see what it looks like and trying to paste it didn’t work either. Anyway, all I get is a blank screen with the heading Comodo on top.

I am not sure what the heck is going on and how to fix it. Should I do a complete uninstall using the add/remove programs and then download the program again and install it or is there another fix?

Thanks so Very Much

If I understand correctly you got updated from 5.x or 6.x to v7 and that went astray. I would suggest to follow Most Effective Way to Reinstall CIS to Avoid/Fix Problems by my colleague Chiron. It will provide a reliable and clean starting point.

I just updated my comodo and now i have the same problem with cfconfig.exe box not closing or responding and this has also stalled the update. I have not restarted my pc in fear of having to reinstall CIS, i would like to know if Erics solution solved your problem? I am also using xp pro.


I did try using the revo uninstaller to uninstall the firewall since it was not working properly and I ended up using the Windows firewall while trying to figure out what the problem was. However, when using the revo uninstaller I get getting some sort of screen that told me I needed to close revo uninstalled to complete the uninstall. So needless to say I started looking around trying to figure out what the heck was going on with that since I have never had any issues with using revo uninstaller to uninstall a program before. I eventually just used the uninstall for the firewall to uninstall it.

I did download the firewall again but have not installed it yet. I will go and download the uninstaller tool and follow the rest of the steps and then try installing the program again. Will let you know how that goes.


I ended up doing a system restore while the cfconfig.exe popup was stalling the update from completing the install and i have turned down the update to install the new version for the moment and everything is running fine. I really would like to know if doing a clean install actually solves the problem because it seems like a the problem is with the update so im not sure how a clean install would change anything.

I haven’t tried reinstalling the software yet for the exact same reason as sistasista - not sure how the computer is going to handle my installing the newest version.

I had tried using the system restore after that darn popup occurred during the update but when I would click on the comodo icon to bring up the screen (from the sys tray clicking to open it) or opening it from the start>programs I was getting the blank white screen which is why I originally posted here looking for a solution.

If I could find the link for the older version (not sure which one that is now either) I would download that and install it since I know that version was working without any issues and not allow it to do any updates. Maybe someone can please let me know what the older version was (before this newest update) so that I can look for that download and reinstall that - at least until someone can tell us if installing the update is going to continue to cause these issues.