Firewall or Defense Blocking Programs

I am having repeated problems with programs that are blocked from running until I click “Allow”. The problem is that if I am not there, such as during a download and install, the load eventually fails and I have to start all over when I get back.

I have flagged the programs as Safe in Defense and as a Trusted Application under Firewall. And still they are being blocked.

I keep clicking “Allow” each time that I am here and the programs are blocked, but I can’t be here all the time.

I am running CIS version 4.1.150349.920 on XP with SP-3 loaded.

What else can I do to make CIS understand that certain applications are safe and to stop blocking them.

I don’t know if it is related, but have also had troubles with programs (like Word) that have been considered Safe by CIS and then suddenly return to being blocked, just the way they do right after a new installation. So I keep having to tell CIS (2-3) times that Word (and others) are okay, otherwise they are blocked, too.

Any suggestions would be appreciated.


try custom policy mode in firewall , and safe mode in defense+.
you will see questions then (for firewall questions to make it easy, “treat as outgoing only”), but when you have answered them one time, with remember the answer, it will stay running.

Can you be more descriptive about what the different problems are. Your descriptions are too general and need more information. Please clearly state what alerts are given and what configuration you are running; look under More → Manage My Configurations and see what config is active.

I have used and liked CIS until I tried to configure it to allow an FTP server. I have browsed all your forum posts on the subject, created custom rules and policies to the letter and still no luck. It would certainly be easier if there was a list of programs and their security level, a la Zone Alarm pro, which you could right click and block or allow. this is really starting to hack me off. I am no stranger to computers and/or networking, being an MCSE, MCP, CCNA, CCA and A+, but I give up…

Hate to thread-hijack but I see some very similar issues with my problem.

Server software.

Apache is my main focus. I can access the site fine from the local network and loopback but as soon as I try to access it from the internet I’ve got nothing. (I’m properly port-forwarded and associated with a name server)

Turning off the firewall (to disabled) Unblocks it and I can once again access the server from outside.

Havn’t tried an FTP server but I’m guessing it’d be the same result

I’ve created rules for
httpd.exe (the actual server)
ports 80,443,3306

(one rule each in each direction, for each port. eg port 80 has )

There is no block in either the firewall, defence+ or antivirus logs for any related software or ports.

Internet security is the currently active configuration

Other programs I’ve had to allow the program as well as the port and have done so successfully, apparently this one is different.

Same as paladin551, I’m no stranger to this type of stuff. Have Network+ and A+ myself.

Edit - NM, I found the problem Apparently 3 Seperate!? rules are required for each port. When working with incoming requests. aka servers. The missing one was Global. See here I’m guessing this will fix yours as well paladin551 Port 21 is probably your focus here.

This really should have been listed as blocking though. Really a firewall that blocks should log ALL connections not merely application defined rules.

This should be added to the next version.
A complete firewall block log with the associated block rule.