Firewall not recording rules in v8.2

I been a comodo user since 2008 and i love it. however in this latest version the custom rules are not being saved for certain programs such as Quantum GIS, which is annoying getting a alert every 5 seconds when you already recorded it manually and in the alert. it simply does not record.
is there a fix on the works? this has been going on for 3 weeks with no bug fix.
I already downgraded to version 8.1 because its impossible to use certain programs and getting alerts every 5 seconds.

What you describe sounds like the bug in 8.2 where CIS can’t handle 8.3 Short Filenames, an update to fix this is supposed to come out this week however, as always, updates may be delayed.

heres a video of the annoying bug.
Is there a way to fix this “short filename” bug? its annoying

Just to make sure that it actually is the short filename bug, could you show a screenshot of the Firewall rules? (I don’t know how well you know your way around CIS but just in case I’ll had descriptions of how to get there below)

[ol]- Open the main window of CIS

  • Click Tasks in the upper right corner (Don’t know the translations so this “guide” will be for English version)
  • Expand Firewall Tasks and click Open Advanced Settings
  • In the new window you should see a list to the left, click Application Rules under Firewall
  • Look for the rule created for the application in question, if it has “~” in the filename/path then CIS can’t handle it.[/ol]

If it is the bug you are experiencing then sadly I don’t know a workaround or fix for it, either downgrade to an earlier version or wait for the new version. :-\

[attachment deleted by admin]

Indeed it is the 8.3 Short Filename bug you are experiencing, like I said previously I don’t know of any workaround other than downgrading to an earlier version or waiting for the update.

thanks for your reply. guess all i can do is downgrade again and disable updates. :frowning: if when fixed let me know

Yesterday an updated version of CIS 8.2 was released that fixed the problem. However it did get revoked. We will have to wait a bit more.

still no fixing?

It should be fixed, have you updated to the latest version?