Firewall not playing nice with OpenSSH

I just installed Comodo Firewall yesterday (ver. 4.1.149672.916) and I am unable to connect to this machine via SSH from any other machine. Even with Firewall Security disabled and Defense+ Security disabled, I cannot connect. SSH was working just fine before installing Comodo.

Ive set both the application (sshd.exe) and the service (cygrunsrv.exe) to “Trusted”, which allows any and all incoming and outgoing traffic. I’ve enabled port 22.

I haven’t received any popup messages about it, even though the Alert Frequency Level is set to “Very High”. I’ve also set the Stealth Ports Wizard to “Alert me to incoming connections and make my ports stealth on a per-case basis”. There aren’t any blocked messages about the IP I’m trying to connect from, except for 4 from yesterday. There are no messages in the logs from today even though I’ve been trying to connect for hours, so it seems it’s not blocking the IP anymore, yet it still doesn’t work.

Additionally, remote desktop is being blocked by it unless the Firerwall is set to disabled. I just set the firewall to training mode and got kicked off, even though I am allowing port 3389.