Firewall not filtering traffic or showing connections [M377] [v6]

A. THE BUG/ISSUE (Varies from issue to issue)
Summary - Give a clear summary in the topic subject, NOT here.
Can U reproduce the problem & if so how reliably?:- Very reliably
If U can, exact steps to reproduce. If not, exactly what U did & what happened:- I setup my Firewall to custom mode and every program connect with internet without popups.
If not obvious, what U expected to happen:- Firewall works correctly
If a software compatibility problem have U tried the conflict FAQ?:- No software compatibility problem,as far as I know
Any software except CIS/OS involved? If so - name, & exact version:- No other software except CIS/OS involved, as far as I know
Any other information, eg your guess at the cause, how U tried to fix it etc: Reinstall

Always attach - Diagnostics file, Watch Activity process list, dump if freeze/crash. (If complex - CIS logs & config, screenshots, video, zipped program - not m’ware) Yes

B. YOUR SETUP (Likely the same for each issue, so you can copy forward)
Exact CIS version & configuration:- 6.1 2801, Internet Security
Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:

  • No Hips
    Have U made any other changes to the default config? (egs here.):- Firewall Program rules On
    Have U updated (without uninstall) from a CIS 5?:- No
    if so, have U tried a a clean reinstall - if not please do?:- Yes
    Have U imported a config from a previous version of CIS:- No
    if so, have U tried a standard config - if not please do:- No, and I want control over in- and outgoing traffic
    OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
    Win 8 , all updates, 64 bit, No UAC, Admin, No V.Machine;
    Other security/s’box software a) currently installed b) installed since OS: a= Malwarebytes, ) (Hitman Pro), Sandboxie b= as a)

[attachment deleted by admin]

Could you post the network connections information and the Killswitch report please.


[attachment deleted by admin]

You have a number of processes in ‘Listen’ and ‘Time Wait’ states but nothing is showing as connected. If you have any log entries actually showing established connections, could you post those and also your firewall application rules.

Yep, but this time on video:

I would really like to see the CIS logs if you have any please. It would also be helpful if you would enable IPv6 filtering before trying again.

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may or may not communicate with you in the forum or by PM/IM, depending on time availability and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again


I am on IPv4 but i checked IPv6 and the result is the same!

I installed Kaspersky and everything is fine.Just for the test my system.

[attachment deleted by admin]

You are welcome!

For what it’s worth, you appear to be running Windows 8, which, unless you’ve explicitly disabled IPv6, is running by default. This allows the system to use a variety of tunnelling methods for IPv6, such as Teredo and 6to4. Unfortunately, CIS and IPv6 are severely broken and quite dangerous. At the least, I recommend, enabling IPv6 filtering.

In the image below you can see a similar scenario. Connections don’t show, Chromium is connected, there are no rules and the system is using Custom Rules and Alerts are on very high.

[attachment deleted by admin]

Can you please check and see if this is fixed with the newest version? Please let us know whether it is fixed or you are still experiencing the problem.

Thank you.

PM sent.

This bug is fixed in new versoin.


Thanks for checking this. I’ll move this report to Resolved.