Firewall not asking about some applications

I’m having a problem with the Firewall.

Whenever I start Firefox, or Skype for example, the Firewall doesn’t ask me if I want to allow them to connect to internet.
How do I fix it so Comodo Firewall warms me about any program?

And also, I’m not sure where can I see all the applications that have a rules already created by me, I mean, what applications I already approve to connect, or the ones I blocked. Where can I see that in case I need to make changes?


To Set the firewall to Custom Ruleset (Also alert for safe applications)

[ol]- Open the Main CIS Window

  • Click Tasks in the upper-right corner
  • Expand Firewall Tasks and click Open Advanced Settings
  • Locate Enable Traffic Filtering in the list of settings (should be at the top) and click the drop-down menu and select Custom Ruleset
  • Click OK[/ol]

To see the existing rules for the Firewall

[ol]- Follow Step 1-3 in the instructions above

  • Click Application Rules in the left menu[/ol]


Now it goes as I like.

Thanks for the answer.