firewall keeps reversing back to previous version on startup of pc [RESOLVED]

HI i felt if i posted my problem in a new thread hopefully ill get help.I had problems updating from 3.020.20 to 3.021.29.Then i was told to restart as admin and this updated the firewall or so i thought.Everytime i boot up my pc the firewall reverts back to 3.020.20.Then it says there are updates available but it will only update if i am admin again.but when i boot up again next time it will have reversed back to 3.020.20 again.

ps i tried to uninstall cpf but even thoiugh i deleted everything that needed to ber deleted including legacy keys it still only was on 3.020 when i thought i nstalled the newest version(3.021.29)

using vista home premium.

thanks in advance

Did you follow this?

followed it word for word.

Have you tried using a good Registry cleaner?

like which i dont want to wreck my system.

99% of registry cleaners come with back ups. I use CCleaner and WinOptimizer. Glary Utilities is also a good one.

I just dloaded CClean.I used that before when i had xp.

so your saying my best option is reinstall.havent time today will try it tomorrow.anyonelse got a different fix.

Just be sure to download the latest version and not keep using an installer you have saved.

ok im fed up. Tried to reinstall twice, Followed the instructions as directed.Removed all the references to commodo etc .I thought i was doing it fine as windows on reboot recognised no firewall turned on.I installed the latest installer on commodo site CFP_Setup_3.0.21.329_XP_Vista_x32 but once it installed it still said 3.020.20.

i need help.:frowning:

Sorry but there still must be traces of Comodo left prior to the install. I actually use Revo Uninstaller in advanced mode and when Comodo says reboot,dont and click next on Revo then delete all registry and program entries. Then reboot. Use CCleaner registry cleaner and reboot. Manually look for any other files and use that clean up link. Then reboot.

i used both revo and cclean.

to make matters worse i just had to use my restore point.As cfw kept crashing the pc when i turned off the firewall.
I think im gonna wait for a new update and see if that updates automatically.

had time so i tried reinstallinfg again .Deleted every hint of comodo i could find including some i hadnt found before but still it only installed version 3.020.

is it possible a vista user can come up with a list of what should be deleted.(i know its a lot to ask)

when run as admin comodo is vers 3.021.29.Is there a way to open comodo when the pc boots up as admin?

Today i finally have the updated version of comodo pf working properly.Only took like seven reinstalls to finally get rid of every hint of previous version.Please i hope comodo next update works as an auto update cause this is too much hassle.

Great news that this issue now seems to have been resolved. I’ll close this topic now. PM an online moderator with a link to this topic if you should need it opened again.