Firewall keep asking access again and again!

Hello guys!

I was wondering about the behavior of my Comodo Firewall…

It keep asking ame to allow access for some programs that I already did…!

I always ask it to create a rule and not ask me again in the future about aplications that I trust, but it keep asking me…

From yesterday I already allowed more then 15 times outlook to acccess internet… As internet explorer too! I already asked to not ask me anymore in the future… to not warn me when IE or Outlook are being a hiding application… To let them have this behavior… but it keeps asking me…

Is it normal? What should I do?

Thanks for your time,


Go at “Security”-> “Advanced” and check the option “basic pop up logic”
If you see no improvment check also the option “automatically approve safe applications”


Thanks for your reply!

I saw my settings, and its already in that way you asked me to configure?! ???

I opened outlook today about 10 times, and it made the same question to me about 4/5… :-[

Thanks for your time,


do you have the latest version of CPF? Is the version


Yes, I do.

I believe I have found the source of the pop ups… Its something about the component monitor… After that I have disable it, the popups almost stopped…

Could be it?

Thanks for your time,



I am getting the same problem. “Basic pop up logic” was already selected. I ticked “automatically approve safe applications” but that has made no difference.

I used to get similar symptoms with Mozilla Firefox, until I went into the Component Monitor and allowed access for a couple of DLLs… Strangely, the DLLs were associated with my Logitech mouse! I suspect you might have to do the same. Just be sure to do some research on the files first before blindly accepting them.

Hi eliminster Im haveing the same problem thought it was just me.I looked into the component monitor every thing looks to be in order there so Im lost to so if you do find out how to do it I love to know thanks.jyss

Hi, Comodo know of this problem and are working on an update. You can turn off (under behaviour analysis) Monitor COM/OLE requests and Monitor Windows Messages and this should solve your problem temporarily until the update.

Hope this helps,

In addition to my last post you can see the reply by egemen (No. 15) which gives some information.,369.15.html


Just a thought - `Did you have the mouse gesture extensions for FireFox loaded? If so, that could be the connection between the logitech dll’s and the firewall warnings.

ewen :slight_smile:


the latest update (today) should have fixed a bug that was causing something similar. pls update and see if you still have this problem.

Also, Ewen, you had noticed a slowdown, again today’s update should have fixed it, can u pls check and confirm.

Much appreciate it.


Just updated CPF and the problem appears to have gone. Also, updated CAV and so far excellent job keep it up.
(B) (L)


Phew… it was a nasty bug, but no more :slight_smile: I am sure there will be others but keeps getting better and better.

BTW: did you notice the mem usage reducation in CAV?


Yes I sure did :wink: My computer seems to be running much faster and sufficiently now. Excellent work.
(L) (B)


Ewen - no, I didn’t, but good reasoning! I currently don’t have any 3rd party extensions installed into Firefox. It was a while ago that I did the research, but it seemed to suggest that the Logitech applications were safe. I think one of the files was called em_exec.exe, in the Logitech Mouseware directory. I just figured Logitech were trying to do some clever things that CPF was interpreting as potential trojan activity.