"Firewall is not functioning properly"

After the last comodo update this happen: “Firewall is not functioning properly”
When i run the diagnostics, it tries to fixes the error but no success, so heres the report.

[attachment deleted by admin]

Same problem here!
Report attached.

[attachment deleted by admin]

Same here. Have rebooted and run diagnostic several times. The last time Windows warned that cpconfig had stopped working. Previously I was asked to install a Comodo network file. Any clues yet on what’s gone wrong? My report is attached.

UPDATE: Considered all the various fixes posted here and in other threads, even opened up the registry and poked around a bit, then before actually doing any of them I let Comodo try to fix the problem one more time. Voila! This time it worked. I had gotten a popup notice earlier that Comodo updates were available and clicked to go get them, but nothing seemed to happen. Maybe they’ve quietly fixed the installer problem, or maybe it was just my lucky day. Good luck to all the rest with this problem, right now I’m happy.

[attachment deleted by admin]

Same problem. It tries to repair the problem by installing COMODO Network Service driver, which apparently fails. I have a copy of the diagnostics report, if needed. I’m running Windows Vista Home Premium Service Pack 1.

I contacted Live Support about the problem and they told me to uninstall COMODO and reinstall the latest version in Safe Mode with network support. I did and everything works now.

Same here… only that I noticed the next day the tiny change in the COMODO task tray icon that something might be wrong… Now my Vista PC has been without a firewall almost 24 hours. Great… what are the odds that I’ve been infected? I have always applied all updates from windows update if that matters.

I mean if something as important as FIREWALL stops functioning, COMODO should immediately stop all the traffic and show big dialog to the user that your computer is now vulnerable. Don’t you agree?

I see theres more users with this problem. So no one can help us?

I went to safe mode with networking, and uninstalled COMODO there. Then rebooted normally, and installed it. Seems to work normally now. Still curious whether I might’ve been infected while the firewall was quietly accepting all traffic…

The problem has to do with the Comodo network driver not being installed in the network card interface. For example, if you look in you network connections properties in Vista/XP, you should see the driver installed. When the firewall shows a problem, Comodo can’t reinstall the driver.

For example, I tried to reinstall the driver manually, but Windows couldn’t find the driver. Just go to your network connection, click “properies,” “install,” and click on the “service,” and the comodo driver will appear if it’s not already installed. This is most likely a bug in how the Comodo driver interacts with Vista/XP. This has happened in the past two updates (3.8 and the later 3.8 version).

:frowning: I had a similar question before, and no one from Comodo answered, considering having the firewall effectively off is unacceptable! However, The Defense+ would cover for it, since closed ports are still ok, and much better than open ports, unless you had some file sharing server running or something…

Here is my question before I learned the “hard way” about the root of the problem:

Same problema on Vista Home Premiun x64 and CIS x64 version with the last update.

I execute Miscellaneous → Diagnostic twice: the second try, after accepting the Comodo Network Services installation, I answer that the comodo service process is an “updater/installer” to the Comodo System checker (Antivirus and so on) also enabling the following install mode request (the first try I only have accepted the single requests).

In this way the Comodo Network Services installation success and at the next restart the all was good: the firewall too!

Hope this help!