Firewall is blocking all connections from home

I brought my work laptop home. The firewall works great at work. When I connect it to my home network the firewall disabled all outgoing connections. When I turn off the firewall then I connect out going.

If you have any ideas how I can try to fix this problem I would appreciate it. I’ve wasted my home afternoon dealing with problem. It’s starting to ■■■■ me off (rant over).

Here is the link to the images in case they aren’t displayed inline.

For some reason the network mask of is not right. It should be

Editing the Global Rule accordingly should fix the problem.

Even then the other entry below that is valid and would work, also even if every allow outgoing rule was deleted from the global rules, CFW wouldn’t block it unless a rule to block an outgoing connection was set.

@kathyjudd when you connect to your home network do you receive a valid IP address? Check with ipconfig by opening a command-prompt then run ipconfig and look next to the IPv4 address field, make sure it does not start with 169.254

Yes, I get a valid ip address. The network connection is fine. I can turn off the firewall then everything works.

I’m back at work now and the firewall isn’t working at work either. I don’t have any rules that says block outgoing connections.

Do you have Filter IPv6 enabled? If so try turning that setting off. Does any application rule have a block rule defined try removing those block rules and see if the application can make outgoing connections. Also check the firewall log for any blocked events.

I switched the configuration from Comodo-Proactive to Comodo-Firewall and it started working. It must be configuration issue.