firewall installation failed windows 10 preview build 9926

Warning to those running Windows 10 Technical Preview; The new Windows 10 build 9926 did as usual trash the Firewall component for me (This seems to be an isolated issue for me only) but when trying to re-install CIS I am presented with a Program Compatibility Assistant Blockage that simply won’t let me install CIS; Disabling the Program Compatibility Assistant doesn’t work in Windows 10 meaning if you update to Windows 10 Technical Preview 9926 and for some reason need to uninstall CIS then you CAN NOT install it again! (If someone knows a way of installing it again then please share)

I’ll be reverting to the previous version of the technical preview, some of the changes Microsoft did makes me gag.

Edit: After further testing I have found that you can install CIS by extracting the CIS installer from the CIS installer and then running it by itself… Those who know what I mean know what I mean; Will test if I find any compatibility issues.
Edit 2: Initial testing suggest CFW works fine; at least with HIPS and Firewall - Haven’t tested Sandbox.

Install windows 10 build 9926
CIS 8 is not installed. Writes “This program has compatibility issues”
CIS 7 installed without problems. How can this be?

[attachment deleted by admin]

Not sure about the different versions acting differently, what you could do is extract the x86/x64 installers from the main CIS 8 installer and the run those, worked for me.

Comodo firewall can’t be installed in windows 10 technical preview build 9926.

Et voila:

It worked for me.

Is it possible to extract the installation files to unzip program like winRAR?

Oh problem solved!!! Thank you!! :slight_smile:

There you have installer CIS 8 x86?

You can get it by downloading the CIS 8 installer that is posted on page 1, then open it with an archiver like 7zip or winrar and navigate to cis > download > installs > xml_binaries > cis and then extract either cis_setup_x86.msi or cis_setup_x64.msi depending on which one you need; After that you simply need to run the extracted installer.

Although be careful, I just got a hips alert that I couldn’t answer because it wasn’t responding to my input and certain fields were grayed out… So it might actually be incompatible…

As they change up more of windows 10 in relation to windows 8 and 8.1 the less compatible its going to be. I figure at some point the application would need a substantial patch to make it work with windows 10.

This was obviously to be expected.

CIS 7 works well.

P.S. If you set the configuration of Proactive Security, we get the BSOD. It all builds of Windows 10

[attachment deleted by admin]

I have recently updated Windows 10 to build 9926. I had CIS 8.0.0.4344 installed on the previous build and after the update CIS firewall showed an error and could not repair itself. The installer would not run and so tried using the control panel to change this. I chose to have only the Antivirus installed and un ticked the firewall box. After a restart I only had the antivirus component so went back into the control panel selected change program and then ticked the firewall box. After a restart CIS had installed the firewall and all is now running O.K

Kept having several problems, errors popping up, PC very slow, freezes - so unfortunately uninstalled and have Avira currently installed until a new version of CIS for Windows 10.

I split and merged the posts in the release topic of 4344 to a separate topic about installing CIS on Windows 10 TP.

With me the sandbox does not seem to work. When I start a browser in the sandbox it does not open. When I open VK it says it doesn’t have Dragon or Silverlight where both are installed.

Does the sandbox work with v7?

Yes

CIS 8.1. not installed, writes “The installer does not support this platform”

CIS 7 installed without problems.

[attachment deleted by admin]

Warning re Comodo CIS and Windows 10TP

I extracted the setup file for the latest version of Comodo CIS and installed it on my PC running Windows 10TP Build 9926. Within minutes Windows shutdown and refused to restart giving me the following error “Stop Error (write To Read Only Memory, Win32k.sys)”. I ended up reinstalling Windows 10TP. That was six days ago and all has been working well sense. I do not intend on reinstalling CIS until Comodo releases a version made for Windows 10.

I had previously upgraded a Windows 8.1 install using the Windows Update method, so I didn’t have to install Comodo. It kept working normally after the first reboot.

Today I had to refresh my Windows 10 and therefore install Comodo from scratch. It ran perfectly after I set the installer to run in Windows 8 compatibility mode. No need to extract it or do anything else. I’ve removed the anti-virus module though, and the only modules I kept active are the firewall and HIPS defense. I don’t know if the rest of the suite would work as smoothly.

That’s good to know! The extraction of the installer was probably only necessary for the previous version of CIS which would trigger a program compatibility issue with windows itself so it wouldn’t let you install, in the latest version of CIS you no longer get stopped by windows but rather the installer itself, so compatibility mode is more likely to work in this new version.

Is the sandbox working with you? What version of CIS do you have installed?

My point is that the installer does say that it is incompatible when you run it, but if you set it manually to the Windows 8.1 compability mode, it will work.

The sandbox worked in a simple test I did right now. I’m running Comodo Firewall 8.1.0.4426.