Firewall ignores Bluetooth networking on Windows 7

I got a new laptop with Windows 7 Home Premium. I use a USB Bluetooth dongle to tether it to my phone in order to access the internet. As near as I can tell, Comodo Firewall (5.4.189822.1355) completely ignores and doesn’t see connections done this way. (It does notice the new networks when they’re created, though.) This wasn’t a problem under Windows XP on my old laptop.

(While I have the alternative of networking via WiFi, I prefer not to do this as it heats up my phone quite a bit more.)

The bug/issue

  1. What you did: Installed a USB Bluetooth Adapter
  2. What actually happened or you actually saw: Network connections via the adapter are not firewalled.
  3. What you expected to happen or see: I expected them to be firewalled as with any other network connection.
  4. How you tried to fix it & what happened: Tried un/reinstalling the bluetooth device
  5. If its an application compatibility problem have you tried the application fixes here?: N/A
  6. Details & exact version of any application (execpt CIS) involved with download link: N/A
  7. Whether you can make the problem happen again, and if so exact steps to make it happen: Try networking via a usb bluetooth dongle?
  8. Any other information (eg your guess regarding the cause, with reasons): Seems that comodo’s network driver isn’t being attached to the Bluetooth network connection. See attached.

Files appended. (Please zip unless screenshots).

  1. Screenshots illustrating the bug: Attached
  2. Screenshots of related CIS event logs and the Defense+ Active Processes List:
  3. A CIS config report or file.
  4. Crash or freeze dump file:
  5. Screenshot of More~About page. Can be used instead of typed product and AV database version.

Your set-up

  1. CIS version, AV database version & configuration used:
    Defense+ and Sandbox are disabled. Firewall is set to Custom Rules.
  2. a) Have you updated (without uninstall) from CIS 3 or 4:
    b) if so, have you tried a clean reinstall (without losing settings - if not please do)?:
    N/A, Fresh install
  3. a) Have you imported a config from a previous version of CIS:
    b) if so, have U tried a standard config (without losing settings - if not please do)?:
    N/A, Fresh install
  4. Have you made any other major changes to the default config? (eg ticked ‘block all unknown requests’, other egs here.):
    Firewall set to Custom level. However this applies to Block All level as well.
  5. Defense+, Sandbox, Firewall & AV security levels: D+= , Sandbox= , Firewall = 5.4.189822.1355, AV =
  6. OS version, service pack, number of bits, UAC setting, & account type:
    Windows 7 Home Premium, 64-bit, UAC on, Admin privileges
  7. Other security and utility software installed:
    Avast! 6.0.1125
    Process Hacker 2.16
  8. Virtual machine used (Please do NOT use Virtual box):
    None

[attachment deleted by admin]

We would very much appreciate it if you would edit your first post to create an issue report in line with the bug forum guidelines and format here. You can copy and paste the format from this topic.

To understand the reasons why we ask you to follow these guidelines please see below.

WHY WE ASK YOU TO FOLLOW THESE GUIDELINES
Bugs/issues can be impossible or very time consuming to fix if developers don’t have enough information to reproduce them. Since CIS is free, development time is limited. So if you want your issue fixed, please use the format below to describe it.

To avoid clutter, issues not described in the format below your post will not be moved to the ‘moderator verified’ issues topic. This means that the developers may not look at it.

Best wishes and many thanks in anticipation

HeffeD

Fixed

Can you try to add the firewall driver manually, by add service, have disk and point it to c:\program files\comodo\comodo internet security see if that makes a difference?

It asks for a file and I pointed it to inspect.inf at that location. However, it doesn’t list any services to add from that.

(I tried it with my WiFi connection also just to see if it would show up and it did list the expected driver.)

Thanks, can you please post the exact details of your Bluetooth driver & device used?

The bluetooth driver is the default Microsoft driver. The device is an Asus USB-BT21.

(Also, I tried the dongle on another computer. It also didn’t pick up the Comodo driver, but it did pick up the VirtualBox Bridged Networking Adapter.)

Thanks, now it’s up to the dev’s to fix it :wink:

Hi ouroborus,

I am an engineer of COMODO, I have researched your bug report, but I can’t reproduce the issue in my lab, I send you a patch for test. please test it based on following steps:

  1.  Open folder “windows\system32\drivers”;
    
  2.  Rename cmdhlp.sys to cmdhlp.sys.org;
    
  3.  Copy the attached files to the folder, reboot machine, notice disable driver signature when rebooting;
    
  4.  Please observe the active connection list and tell me test result.
    

Edit Ronny:
Fixed a typo

[attachment deleted by admin]

RickWang, your account is marked as newbie and, as near as I can tell, you can upload any image you want as an avatar, even one claiming to be staff.

I’m sure you’ll understand when I ask you for verifiable credentials before replacing a driver. I think the possibly easiest way would be for you to get your account flagged as a staff account rather than newbie.

Hi Ouroburus, I can confirm he is Comodo staff.

Hi ourborous,

RickWang is indeed Comodo staff. The “Newbie” tag denotes the quantity of posts, not an affiliation, or lack thereof, with Comodo.

If it helps, I can get Rick to send the replacement driver to me to install first and post the results back here.

Ewen :slight_smile:

I had assumed with titles such as “Product Translator” and “Global Moderator” there would be one for Software Engineer or some such. In any case, thank you for vouching for him.

I’ll get started on getting that driver installed.

Thanks. Please post the results back here as it may help other members.

Cheers,
Ewen :slight_smile:

Seems to be no change even with the different driver. I’m not sure what you meant when you said “… notice disable driver signature when rebooting”. I renamed the file, copied over the replacement from win7.zip/amd64, and rebooted. Windows didn’t seem to be bothered by the whole thing. I did have to “Remove Device” and then “Add Device” to get the bluetooth stuff working again. Otherwise, no apparent change. Comodo continues to ignore that particular network. See attached.

Update: The Event Viewer says cmdHlp failed to load…

2: Figured out the thing about the driver signature enforcement from one of your other posts. Working…

3: The reboot seems to have went as intended. But, sadly, no change. Comodo still doesn’t add it’s driver to the bluetooth connection.

[attachment deleted by admin]

Hi ouroborus,

Sorry for my poor english, I checked the code, and it seems that CIS version 5.3.176757.1236 can fix your issue, please install this version and test.

If any question, please inform me ASAP. you can contact me with MSN: greenfield_wang@hotmail.com.

Thanks for your kindly help!

Where would I go to download that particular version? It seems that old versions are not usually made available for download.

https://forums.comodo.com/empty-t67084.0.html

That doesn’t seem to be the correct version. The post you linked says it’s for version 5.3.174622.1216. The download itself is actually for what appears to be the most recent version, 5.4.68750.1355.

The version suggested for fixing this particular issue is 5.3.176757.1236. Where can I download that particular version?

Hi,

The attached is the related driver file with version 1236, please download and test it.

[attachment deleted by admin]