Firewall Error

CIS firewall is reporting an error, diagnostics couldn’t fix it, just short of re-installing the program, what else can I do???
Error report is included.

[attachment deleted by admin]

I think I have the same issue. Just after installation, the program tells me that the network firewall is not functioning properly and suggests a diagnostic run. Diagnosis says there’s a problem with installation, and when it attempts to fix it, it just says the problem can’t be fixed.

Did a bit of Internet research, this seems to be a long-existing problem since 2008. A 2009 post says running the installer at Vista compatibility mode solves it, I tried it, nothing different. Also tried installing in Safe Mode (doesn’t work at all) and giving it administrator privilege, nothing.

Please please can someone give me a hint? I run a 64 bit Windows 7 Professional.

I remember using the old Comodo Firewall Pro in Windows XP, excellent piece of software, what ashame.

Apologise in advance if I double-posted, tried searching the forum, no clue…