Firewall doesn't work


And sorry for my english.

I’m a COMODO user for many years. In december, I’ve decided to try CIS PRO and installed it.
At the end of try period, I removed it and came back to CIS Premium, latest version.

But the firewall still doesn’t want to launch (error message : the firewall doesn’t work correctly)
Antivirus is ok.
Firewall sends me pop-up when a program starts or goes to the internet.

I’ve tried many things, such as uninstall with the remove tool, in non echec mode, but no effects.

A report was created, the only thing who failed is

I’m running W8.1 x64 and CIS =“6.3.302093.2976”

Does running the diagnostics find any problems?
Also, can you please post a screenshot of the error message you see?


The diagnostic says he detects problems but can’t correct them itself.
It proposes me to create a report
Here are two screenshots and the report.


[attachment deleted by admin]

I’m not sure what caused this problem. However, if you’re willing to reinstall, this can almost certainly be fixed by reinstalling by following the advice I give in this topic.

Let me know if you have any questions.


OK, thank you for your answer. I’ve already tryed all this operations last week, so I did it again tonight (it’s the night in France), but no change, I’ve still this problem.

Did you uninstall normally, then boot into Safe Mode? At that point make sure you ran the CIS removal tool which is compatible with Windows 8, and removal tools for any anti-malware utilities which used to be installed on your computer but are now removed. Also, while in Safe Mode, ensure that the firewall driver has been removed.

Then reboot into normal windows and install CIS.

Even after doing all of that does the Firewall still not work?

Yes, be sure that I’ve done everything just as you said it to me.
I ran the removal tool in safe mode, and after I repeted all the steps in you tuto.
I’ve looked for COMODO drivers, but none found.

And back into normal mode, I reinstalled CIS, but the problem is still there.

Please list any other security and maintenance software currently installed on your computer. That may prove helpful.

Also, I have asked the other Mods if they have any thoughts about your situation.


I don’t have other security products than CIS (and I haven’t any other before).
I also ran the third party remove tool for all the security products and he founds nothing.

As I said, the only thing who changed recently was the test of the pro version of CIS.
When I came back to premium CIS, the first reinstallation shows me that problem.

But during that period, I installed Microsoft MDT, and it came with Microsoft ADK and Performance toolkit, but I never launched ADK and performance toolkit.

If you don’t have a solution, I’ll deploy an old image of my system and I’m sure it will works.
Just say me if you want to try something else.

Thank you for your help.

Before restoring the old image you could probably wait a bit and see if anyone else has any thoughts. Sorry, at the moment I do not have any further suggestions, but that does not mean that others won’t.

I am on stand by waiting for your list of installed security and maintenance software.

When trying a clean installation make sure no other left overs of previously installed security software are around. This is an important step in Chiron’s guide. Then run the CIS clean up tool in Safe Mode.

Then as a finalizing step of the uninstall. Sometimes it happens that the Inspect driver is still present and needs to be uninstalled.

How to uninstall the CIS firewall driver when it stays present? Look up the properties of the network connection, select the Comodo Firewall driver and uninstall it. See the attached image.

I hope that will fix your problem.

Supposedly the below “fix” shouldn’t be needed anymore but who knows, perhaps it will work? Maybe not but it might be worth a try, then you at least know if it works or not.

[ol]- Open regedit.exe

  • Go to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Network
  • If “MaxNumFilters” is present then delete it
  • Re-install CIS according to Chiron’s guide linked earlier in this thread[/ol]

Video demonstration of editing the key: How to edit MaxNumFilters - YouTube

I was very aware of Chiron’s guide, specially for what I never test before.
So I made it twice, one before creating this post, and one after, when Chiron said me to follow his guide (which I followed twice :slight_smile: )
But I never found any driver left. So when I saw your post, I open this priority box to finally see this driver, but I haven’t any driver, even if the firewall is still installed.
Maybe this is the reason ?

[attachment deleted by admin]


Hy, no MaxNumFilters key in my registry.

I tried this :
Properties of network card>install>service.
I see a COMODO section, and three services listed in the right box. The last one is from version 6.2.8161.0 [23/12/2013].

Seems like the latest driver from my installation is not there ?
I tried to install the latest driver (23/12/2013) but no way, he doesn’t found the driver’s package.

[attachment deleted by admin]

The Inspect driver did not get installed on your system. Try installing the driver using the Have disk route (Disque fourni…). You can find the inspect.inf, and inspect.sys in the installation folder of Comodo Firewall.

Hy, good news ! Problem solved !
With the driver’s installation, the firewall is now ok !

Thanks again !

Glad it worked out for you. :slight_smile: