Firewall doesnt work, wifi is blocked,firewall driver might cause problem[FIXED]

in short:
Comodo Firewall and wifi are not working, the “Comodo Internet Security Firewall Driver” seems to cause this problem. Turning off this driver allows the wifi to work properly and the firewall still is not.

in long:
After installing Comodo Firewall its diagnosis reported an error. I used the automated debugger to analyze and solve the problem. An driver was installed (what i suspect to be the “Comodo Internet Security Firewall Driver”). After booting the error reports where gone and a diganosis with the comodo diagnosis tool turned out empty even though the firewall was not working (no blocked/outgoing/incomming processes reported in the overview) and my wifi was not working stating “Limited Access”. Reinstallation didnt solve the problem. Eventually i found the “Comodo Internet Security Firewall Driver” in the wireless connecton properties and turned it off. The wifi was working again but the firewall still wasnt. After reinstalltion following your advices it seem to work. The Comodo system tray icon indicated traffic, the overview indicated blocked/outgoing/incoming processes and the wifi was working properly stating “Connected”. After a boot it was back to where it was at the beginning.

My guesses are that there are some conflicts with the “Comodo Internet Security Firewall Driver” or my Comodo Defence is blocking some firewall processes (it is set to “paranoid” and i might have been blocking some firewall processes without recognizing).

Thanks in advance.


I am using an Asus Laptop x50v with Win7 x86 professional. Avira Antivirus is operational, Win Firewall is turned off.

Limited access usually indicates there are issues with assigning IP addresses over DHCP in the average setup.

There are 2 things you could try:

  1. switch the firewall to ‘disabled’ reboot the machine and see if it’s working then.
  2. switch CIS to an other security profile and leave that ‘default’ for a while to see if it breaks or keeps working.

One thing that might help is to note the output of this command executed in the command-box (Start, Run, cmd).
ipconfig /all

I suspect that in case of ‘limited’ access the IP starts with 169.254.x.y.

yes, in the case of limited access the ip is changed from 192.168.x.y to 169.254.x.y

it would have been so much easier if one could read. of course i did put my firewall to “block all”. I assume I might be used to this setting from previous CISs that it means “always ask me”. Thanks for your help.

If I understand correct the issue is solved?

Getting the most alerts out of the firewall is done by putting the security level on: ‘Custom Policy’.
Setting Firewall → Firewall behavior settings


  • Create rules for safe applications
  • Enable IPv6 filtering (if applicable of course).


  • Do not show popup alerts

Switch to ‘Alert settings’
Set frequency level to high or very high to your personal liking.

Yes, the problem is solved. Thanks.

I have had the firewall set to “block all” and it did excatcly that. It blocked everything.
I have now set the firewall to “custom policy” and everthing is perfectly fine.

So the experienced problem was not an error but an intended feature. A feature i like very much, i must say. So in the in the real problem was that i just didn’t read carefully through the discriptons of the firewall settings, because i though i knew it.

Okay no problem, glad it’s fixed :-TU