Firewall doesnt work on windows 7 pro x64

Hello guys, i’ve just installed windows 7 professional 64bit
I’ve installed CIS too (lastest version of cispremium_installer_x64),
After a reboot i lose the connection between my PC and the router!

This is what i did:

  • Disable windows Firewall
  • Install Comodo
  • Select that i dont want comodo DNS
  • Reboot

When the system restart, i’ve a ! on the comodo icon in the task bar, and the application says that the firewall doesn’t work.

If i do a ping on the router address (192.168.0.1), it doesnt answer, even if I disable the firewall. Ping on myself works

I tried to do a ping 192.168.0.1 -t
Uninstalling comodo, ping starts working again and the internet connection too

What can I do? thanks in advance

Have you tried to use “diagnose”?

What router are you usiing?

If nothing helps uninstall CIS (comodo internet security), clean the remaining registries from CIS with CSC (comodo system cleaner) https://forums.comodo.com/news-announcements-feedback-csc/comodo-systemcleaner-30-build-37-released-t64348.0.html or any other, install CIS again but keep Windows firewall on; you can always disable Windows firewall after the reboot.

I hope I could contribute with some help.

Regards,
Valentin

Well, just resolved! :slight_smile:

I would tank you for suggesting CSC, I didn’t know this program and it’s great!
By the way I’m not sure that it was the solution, because the first installation was after a format and windows update, so the system should be celaned.
On the last try I’ve cleaned the system with CSC and i left the path folder unchanged (c:\Program Files\xxx), because I’ve always changed in c:\Programmi\xxx (Italian version)
I dont know wich one was the solution but, finally, it works!

P.s.: Yesterday I tried many times to use diagnostic without any result

Thanks for help

I am happy to hear that everything is working! as it should :slight_smile:

In cases the diagnose tool doesn’t fix anything try to save the error that it has found and then send it to comodo or send it here to the forum (to the CIS bug forum, to be more exact).

Regards,
Valetnin