firewall doesn't start

my comodo firewall pro(ver 3 with latest version)always throws up a ‘network firewall is not functioning properly’ error no matter what. i tried the diagnostics and it said the problem was fixed but when i reboot the error messages appears in the main window. i m using winxp sp2 with avast, spyware doctor, spybot and adaware.

To Too456,

I have that exact same configuration with exception of spyware doctor. But I had tried a free trial of spyware doctor and its a very aggressive program that tends to cause conflicts with other software.
Other than going start—run—then typing msconfig in the dialog box—and then checking to see if CPF3 is still on the start up list, I don’t see a real easy way of checking to see if CPF3 is starting up at all at boot time. But you evidently have the CPF3 shield on the taskbar and you can open it up to to diagnostics. Lots of other things you can check in network and D+ to see if you can find anything obvious. Log files, errors, setting, etc. But if you don’t know whats normal, its hard to see abnormalities.

But if I were in your situation, I would suspect a bad install or conflict. And the first thing I would try is----

  1. Go to add remove programs and remove CPF3.
  2. After the reboot, I would go and remove the CPF3 directory which still has contents after CPF3 is removed. So get rid of the directory to make sure nothing bad is remembered.
  3. Find some utility that will prevent spyware doctor from starting up at boot time. (I use start up cop but there are others ) Then I would make sure the sp2 firewall is shut down using the control panel.
  4. Then I would do a clean reinstall of CPF3. Get it up and running correctly while making sure that
    the sp2 firewall is still shut down ( Yes the sp2 firewall does have an annoying habit of turning itself back on )
  5. Then go to your utility, put spyware doctor back on the start up list, and then reboot. And again see what happens.

If the problem still persists, or you get problems before getting to step five, you can still get various clues on where the problem may be.

Try that and post back, and its also possible someone else may suggest something better and different. And come to think of it, you might check to see if you have any other HIPS software running on your computer—and its conflicting with the D+ part of CPF3. And spybot does have an optional HIPS that could be conflicting—so check to see if its enabled or disabled in your copy.

i tried your suggestion to the extent of uninstalling spyware doctor and spybot but to no avail. it seems that the diagnostic does not actually tell you what error occured. if there is a way to find out what error occured, it would be extremely useful.

The only idea I could give you is trying a reinstall… :-\ This kind of problems might be caused by antivirus/antispyware programs, but at the time of installing: the file protection offered by these programs may interfere with installations, specially of other low-level security programs, so it’s always a good idea temporarily disabling them while installing.

i already tried everything…even starting in safe mode(without any internet connection or antivirus/antispyware programs starting) and installing it there… it seems that when i restart after reinstalling it takes forever to load windows. all i can see is the windows xp logo+the little loading animation which goes on forever and ever. the only way i can get in is via Last Known Good Configuration. is there anything wrong by doing this?