Firewall doesn't see application connections

Hello!

After installing windows updates, I have restarted my computer and now CIS can’t see any application connections, so it reports any connection as a Windows Opearting System connection.

No mater how many applications are connecting to the internet, it always has only one System connection.

I have tried to reinstall CIS, no luck.
While updating windows, I was connected to VPN with OpenVPN, I have uninstalled OpenVPN, it didn’t help.
Please see images below:

http://i45.tinypic.com/29sb6f.jpg

http://i45.tinypic.com/zufspi.jpg

So, it reports any connections as Windows Operating System connections:

http://i48.tinypic.com/30hyolv.jpg

Any help with that?
Thank you.

COMODO driver is installed correctly:

http://i48.tinypic.com/1ibx2v.jpg

I have restored my PC from two-weeks-old system image, and at the beginning COMODO worked fine, but then I have updated it to the latest version and it stopped working again.
The same problem, COMODO doesn’t see any connections except System!

COMODO version: 5.12.256249.2599

Hi lokiby,

You aren’t the only one to encounter this problem as shown in this post to https://forums.comodo.com/firewall-help-cis/512-all-traffic-goes-through-windows-operating-system-t88285.0.html

It seems to be a bug in version 5.12. The developers are aware of it and fixing it.

Oh, thank you Boris!