Firewall doesn't ctrl ntwk activity whn RRNetCap Driver enbld on x64 [V6][M621]

A. THE BUG/ISSUE (Varies from issue to issue)
[ol]- Summary - Give a clear summary in the topic subject, NOT here.

  • Can U reproduce the problem & if so how reliably?: The problem reproduces after clean install of latest version.
  • If U can, exact steps to reproduce. If not, exactly what U did & what happened:
    a: Uninstalled CIS and rebooted.
    b: Installed CIS
    c: Try to create block rules for individual applications
  • If not obvious, what U expected to happen:
  • If a software compatibility problem have U tried the conflict FAQ?: There is no problem reported in FAQ.
  • Any software except CIS/OS involved? If so - name, & exact version: Audials One (Audials One Multimedia Recorder).
  • Any other information, eg your guess at the cause, how U tried to fix it etc: The problem caused by RRNetCap Driver (RapidSolution Software AG). Disabling this driver restores the work of firewall. The problem is not observed on x32 system with same configuration.

B. YOUR SETUP (Likely the same for each issue, so you can copy forward)
[ol]- Exact CIS version & configuration: Comodo Firewall 6.2.285401.2860

  • Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV: Default Firewall configuration with disabled GeekBuddy and Antivirus.
  • Have U made any other changes to the default config? (egs here.): No
  • Have U updated (without uninstall) from a CIS 5?: No
    [li]if so, have U tried a a clean reinstall - if not please do?: N/A
    [/li]- Have U imported a config from a previous version of CIS: No
    [li]if so, have U tried a standard config - if not please do: N/A
    [/li]- OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used: Windows Seven Ultimate SP1 x64, under admin with disabled UAC.
  • Other security/s’box software a) currently installed b) installed since OS: a=Emsisoft Antimalware b=Sandboxie 3.81.08

Disabling Emsisoft does not affect this issue.

There is no any problems found by Diagnostics tool. The driver that caused the problem is attached. The Diagnostics Report, and Process List, are attached to this post. The zip files contain both.

[attachment deleted by admin]

Please try disabling Emsisoft temporarily and see if that solves the issue. I don’t think it will, but it would be very helpful for this bug report if you could confirm that disabling it does not solve the problem.

In addition, please attach the diagnostics report, even though no problems were found, and the KillSwitch Process List. It’s possible that the issue is more complex than just an incompatibility with the driver. Thus, before I forward this to the devs I have to make sure that they have enough information to troubleshoot the issue if it does turn out to be complicated.

Thank you.

Thank you for your quick reply.

Unfortunately I cannot perform above mentioned actions because the system was tweaked already and I haven’t neither access nor desire to adjust everything once again.

Same for you I don’t believe disabling simple resident monitor will change something in network drivers work.

And I am sure everybody can reproduce the problem with simple installing CIS 6 and Audials One on Win7 x64 without any additional changes in settings. If I am wrong then devs will not be able to help me because it was not Comodo issue.

And now - it’s up to you to inform devs about this case or not.

Once again thank you for your work in cleaning all these cases and sorry I cannot give you some more information.

I tried, but am unable to reproduce this. Please attach the requested information, and ensure that Emsisoft is not a complicating factor, so that I can forward this to the devs.

Thank you.

OK. I have stopped Emsisoft Antimalware (but didn’t unload it from the systray).
Here is logs when driver was enabled and firewall could not control network activity:

And here is - with disabled driver and firewall works OK:

I have added process list from Process Explorer to above mentioned archives - sorry, but I cannot install KillSwitch because of policy.

[attachment deleted by admin]

No problem. Getting the process list from KillSwitch wasn’t the important part. It can be created with any program. I just mentioned KillSwitch because it’s most convenient for most users. Your list is fine.

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may not communicate with you in the forum or by PM/IM, depending on time availability and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again.

The latest build (6.3.294583.297) solves the above mentioned issue partially: “Block All” works OK now, but blocking rules for separate applications doesn’t work with enabled RRNetCap driver.

Thank you.

I have updated the tracker.

I have received word from the devs that the buggy part of this has been fixed, and what is still experienced is not a valid bug. If you do not believe that is correctly please respond to this topic and send me a PM (with a link to this bug report).

I will now move this to Resolved.

Thank you.

Yes, it was fixed. Thank you.