firewall doesnt block anything

hi all,

Heres my problem: Ive had Avira AV and Comodo FW installed for quite a long time. Since Ive been having RAM problems lately, I decided to go with Comodo only and this morning I installed comodo cis6 to my XP system.

It updated over the old comodo fw installation, i spent some time in the settings and then turned wifi on again. I opened google chrome, and saw that it connects to the internet, even though it shouldnt because theres no application rule that allows chrome. Firefox connects too, and so does openoffice update!

So i uninstalled and reinstalled from a scratch, thinking that perhaps the new comodo inherited the firewall settings from the older version yet fails to show them on the settings screen. But no! Same thing happens again–applications keep connecting to the internet even though i dont have a rule that allows them to!


By default trusted applications, such as Chrome, are allowed to connect to the internet. To control this you must make certain changes to the configuration.

Please let us know exactly which changes to the configuration you tried to make?

I havent done much really. Ive just deleted the rules that allow System and Update executives to connect.

“create rules for safe applications” is unchecked, so why exactly does my firewall allow these applications to connect to the internet?

Ah, create rules for Safe applications actually needs to be checked. Also, I believe you need to increase the alert frequency.

Sadly I’m not entirely sure about every change which should be made, but hopefully someone else can provide more detailed instructions.

Maybe some where in the programs (setting) is to check for updates?

Using the custom ruleset may help.
Also editing the settings for applications to ask.

The default setting of CIS6 will not create firewall rules for safe applications. It will not even question any connection attempts. Personally I like it that way because I don’t get needless registry entries cluttering my system and all my games and other programs can update seamlessly without annoying popups. As Chiron said, if you want rules created that box needs to be checked.

Sorry but Chiron and Dch48 are TOTALLY wrong. If you go and read Comodo help files, it says there. :wink:

Correct answer was by…

…Mrarnold!! applause Thanks a lot! I’ve been trying since morning, and didn’t think to change the “Safe” setting to “Custom” setting. :smiley:

I was not TOTALLY wrong. If you want rules created for everything while the firewall is in the default Safe setting, you have to check the box to create rules for safe applications. You will not get any popups though for those apps. Changing the firewall setting to Custom will give prompts for all connections. If that’s what you want and can live with the annoyance, so be it.

Annoyance? Like opening the door when a friend is pressing the bell? And you just have to allow this friend only once, in contrast to a real door?

It can be annoying if you think that you have to take in concideration how the clothes of this friend are, which color they have, what the haircut is, etc… Or if you dont get rid of unrequested attempts by a gloabl rule.
But you can simply allow “the friend”. Once. And block all the rest automatically.

It’s an annoyance if it happens in the middle of a large game update and borks the whole thing so you have to start over. For a large portion of the computer users, any alert for a safe application is an annoyance and makes them think they’ve encountered a virus.

Keeping them sheeps…

If you tell people:
Allow what you start. Block the rest!
You enable them to be safe.
And if something happens out of this line, they know that they have to be suspicious.

An automatism program may and will fail sometimes. And the people can not decide if its a virus, or just not whitelisted.

Follow easy rules, which are not dependent on other things.
That keeps you safe. Even if X fails.

I “can” send you a digital signed malware. And you can watch it sending.
Send me such a file… it will not send.