Firewall does not block traffic in "Block All" mode [NBZ]

The bug/issue

  1. What you did:

Bought a new machine, installed Win7 - and Comodo CIS first thing!
Then just browsing the net, using dropbox, skype etc.

  1. What actually happened or you actually saw:

I missed all the firewall alerts I was used to with XP. No icon animation (yellow carets).
Then I openend CIS and saw:
0 outbound connections
0 inbound connections
No traffic shown in the details pane.
Then I ticked “Block All Traffic” but Internet present like before.

  1. What you expected to happen or see:

Traffic shown by CIS
TRhen - after blocking all - Skype logging off and being unable to browse.

  1. How you tried to fix it & what happened:

I saw that Windows firewall was on.
Download latest CIS version.
Uninstall CIS, clean registry, turn off Windows firewall, reinstall CIS
CIS still doesn’t display connections or traffic.
CIS still doesn’t actually block traffic when told to do so.

  1. If its an application compatibility problem have you tried the application fixes here?:
  2. Details & exact version of any application (execpt CIS) involved with download link:
  3. Whether you can make the problem happen again, and if so exact steps to make it happen:
  4. Any other information (eg your guess regarding the cause, with reasons):

Have I caught a trojan which blocks firewall?

Files appended. (Please zip unless screenshots).

  1. Screenshots illustrating the bug:
  2. Screenshots of related CIS event logs and the Defense+ Active Processes List:
  3. A CIS config report or file.
  4. Crash or freeze dump file:

Your set-up

  1. CIS version, AV database version & configuration used:

5.3.181415.1237
8038
“Block all trffic”

  1. a) Have you updated (without uninstall) from CIS 3 or 4:

clean install

b) if so, have you tried a clean reinstall (without losing settings - if not please do)?:
  1. a) Have you imported a config from a previous version of CIS:

no.

b) if so, have U tried a standard config (without losing settings - if not please do)?:
  1. Have you made any other major changes to the default config? (eg ticked ‘block all unknown requests’, other egs here.):

No change at all

  1. Defense+, Sandbox, Firewall & AV security levels: D+= , Sandbox= , Firewall = , AV =

Block all traffic

  1. OS version, service pack, number of bits, UAC setting, & account type:

Win7 64 (SP1 not installed)
UAC: Default
Administrator

  1. Other security and utility software installed:

CrapCleaner
Revo Uninstaller Pro

  1. Virtual machine used (Please do NOT use Virtual box):

no

Thank you for your bug report in the required format.

Moved to verified.

Thank you

Dennis

Meanwhile I tried to install Agnitum’s Outpost Security - with no luck at all. Their installation failed to load the kernel driver AFW.SYS.
Maybe a problem with some service which must run?

Solved.
I found a crippled GigE-Camera-Network-Driver which wasn’t completely removed after a failed installation.
I uninstalled it in TCP/IP settings. Now Comodo is working again like a charm.