Firewall disregards answer directly before a new (identical) popup

Firewall disregards answer directly before a new (indentical) popup

When a (new) program tries to access the internet, and a Firewall popup is answered to treat the file as a “Browser” and “Remember Answer” is CHECKED, directly after hitting apply, a new (identical) Firewall popup comes up that the program is trying to access the internet, and the use has to, once more, treat it as a browser, and remember answer checked.

The issue

  1. What you did:
    After starting a newly installed application, and answering to treat the program as a browser & remember the answer, a new identical Firewall popup comes up asking exactly the same, thus not respecting the previous user response

  2. What actually happened or you actually saw:
    See 1.

  3. What you expected to happen or see:
    No more popup(s) that the program is trying to access the internet

  4. How you tried to fix it & what happened:
    No

  5. If its an application compatibility problem have you tried the application fixes here?:
    No

  6. Details & exact version of any application (execpt CIS) involved with download link:
    The Proxomitron & Firefox & any other tool trying to access to internet which can securely be configred as a browser

  7. Whether you can make the problem happen again, and if so exact steps to make it happen:
    See 1.

  8. Any other information (eg your guess regarding the cause, with reasons):
    Popup responses not directly taken into account by CIS Firewall.

Your set-up

  1. CIS 5.8.*.2124
  2. a) I updated (without uninstall) from CIS 5.5 to 5.8
    b) I let CIS start from scratch and not retaining my v5.5 rules.
    c) I cleaned out 99.9% of the Trusted Vendors list before running any program.
  3. I did NOT import a config from a previous version of CIS, but started from scratch.
  4. Config used = Proactive Security with all settings to a Paranoid as possible & Sandbox = disabled.
  5. D+ = Safe Mode, Sandbox = DISABLED, Firewall = Custom Policy
  6. OS = Win7 64bit SP1, UAC disabled, account type: Administrator
  7. Anti-Virus = NOD32 Antivirus v5.0.93.0
  8. NO Virtual machine used

you can get the same error massage for Mozilla Thunderbird .
I think it happens when you try to open HTTPS links ,
the default web Browser predefined policy dont have HTTPS in it ,
but technically it should block it .
ya need to think about it

I dont want to say error massage , it should be pop up alert

[attachment deleted by admin]

Subtle one. Please check CIS 6.0 Beta to see if https ports are now included in Browser policy, if not please report in Beta bugs.

Best wishes

Mouse