firewall decision popup broken

applications just get added to the rules as allowed despite this not always being what i want, sometimes i want to block them but dont even know they ran. i used to see a popup asking for an action but no longer. i see a similar thread from awhile ago but no answer to it so decided to just make a new one instead of necro bump. the checkbox to not show alerts is unchecked.

how can i fix this so i get asked on every new connection and not just assume its allowed? i have already purged the rules too from application rules as well

May I ask what CIS version and OS version you’re running?

If Firewall is set to “Safe Mode” and you run a Trusted application then you won’t get Firewall pop up Alerts.

If you set Firewall to “Custom Ruleset” then you get Firewall pop up Alerts for every application not yet listed in the Firewall Application Rules.

Hope this helps.

If Create rules for safe applications is enabled then auto allow rules will be added for trusted applications when they attempt outgoing and incoming connection requests.