Firewall Custom Policy does not work fresh windows 7 64bit install

I had to re-install windows after Comodo Time Machine royally hosed my system(I will not be using it again) and now I am using the new comodo internet security on windows 7 64bit.

Custom Policy mode does not work. no program, ever, has had to ask permission to connect to internet. Firefox, opera, winamp, openoffice, they all SHOULD have asked permission, but no. The only option that seems to do anything in the firewall level is “block all” the rest, don’t block a thing.

How can I force it to actually enforce custom policy and ASK me when something tries to connect?

version 4.0.138377.779

at this rate I will have to go back to the functional old version, just like I have to do for Opera and Firefox

First thing that comes to mind is that you need to remove the “All applications” rule in network application policy, then see if you can get alerts. If it still doesnt work, you can enable “create rules for safe applications” which I dont know where it is at exactly as I dont use version 4 at the moment.

On an informative note. Removing the “All Applications” rule is the same as switching to Proactive Security.

I want it to ask me for permission for every program that tries to connect to the internet… instead of letting absolutely everything through, which it does now.

Then either switch to Proactive Security (and begin from scratch again) or delete the All Applications rule when in the default Internet Security. Then set the Firewall to Custom Policy.

why is it set to allow everything through by default? That’s useless.

It is set to allow safe applications to lessen the amount of alerts for the not so advanced users with the default settings. With version 4 Comodo tries to reach out more to the non technical non geek users who also deserve security.

As you will notice that the old v3.x ways are never far away.