Firewall Control Box (splash screen) opens at startup since last version update

Also having same problem , there was an answer on a previous thread when it was just the firewall and not CIS. - but sods law I can’t find it now , I seem to recall it was a simple explanation about unticking a box then ‘apply’ then re-tick box , I would have thought a seasoned moderator would recall the thread…

ok - finally found it , but not sure how to copy it across
go to ‘ARCHIVE BOARDS’ at bottom of the main forum column. then COMODO FIREWALL > help V3 > then either use help tab or locate topic dated june 25th 2008 started by dbailey 18.

the reply is the one posted by Kail.

I followed this and it worked last time .

You mean this entry, dated June 27th:;msg173903#msg173903

Make sure the -h is in the command line (to hide the splash screen at startup.)

thats the right topic - only the answer from KAIL is the next one down where he provides instructions as to what to do.

This is what i meant :-

By adding “-h” to the command line. Assuming you’ve got everything as default (which you probably don’t, otherwise it should already have the “-h” option), the easiest way to reset this entry is to open CFP - Miscellaneous - Settings - General - uncheck “Automatically start the application with Windows (Recommended)” & then hit Apply. This will remove the registry startup entry. Then go back, check then entry “Automatically start the application with Windows (Recommended)” & hit Apply again. This will create the registry startup entry (with the “-h” option, unless something stopped it).


just a recommendation: when deleting one of the registry keys, one should delete the "COMODO Firewall Pro" entry, because if you delete the other one you won't be able to check/uncheck the box for the relevant option in: CFP GUI-> Miscellaneous-> Settings-> General-> "Automatically start the application with Windows (Recommended)". Moreover, I think that with the next update the CIS entry will be recreated and then you'll have again two entries in the registry resulting in the random appearance of the GUI screen.


That is an interesting theory, Ionathan. Btw, welcome to the Forums.

Although an old thread, I would like to add to it.
The issue is that a Comodo splash screen opened on system bootup or restart.
This only happened on a netbook I have.
The problem is easily solved if you check the “Do not show this again” box in the lower left corner.
However, I had set the “Make text larger” in Win 7 to medium. Thus, I could not find the checkbox. Resetting the screen resolution to normal, I WAS able to see and check the box. Then reset to the size I wanted and now no more splash screen. No registry editing required!